menu and toolbar have disappeared

Asked by Carey

Somehow I have made the menu bar and tool bars in digikam disappear. I have been poking around in the program everywhere I can think of yet I am unable to restore them. Any suggestions?

Question information

English Edit question
Ubuntu digikam Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Ralph Janke (txwikinger) said :

Thanks for the question!

What release are you using? could it be that you have upgraded a library that could not be reloaded without login out and in again?

Revision history for this message
Carey (carey-cimian) said :

Currently running 1.0.0-beta5. This problem first occured sometime ago while running a previous release. I had hoped that the update would fix it but no such luck. I tried re-installing (on Kubuntu) but same problem. I have not tried to delete it completely from the system then re-installing. I was hoping that it would just be a config issue somewhere.

I have been kicking this cat for some time now. I would really like to get this turned around. Any suggestions would be welcome. Cheers.

Revision history for this message
Carey (carey-cimian) said :

Well after some re-reading of the documentation I was able to restore them by repeatedly using Ctrl+Shift+F. Not sure why I had to try it a couple times before it finally worked. Thanks for the assistance.

Revision history for this message
Kermit Hale (kermithale) said :

My desktop menu and toolbar disappeared too, I was trying to correct a different problem: wavy cutmarks through the letters of documents when displayed for more than a few minutes. I must have clicked the wrong button somewhere because the toolbar simply vanished.-
I use: XUBUNTU 9.04 (jaunty); kermel Linux 2.6.28-16-generic; Gnome 2.26.1

Revision history for this message
Andrey (andrey-yandex) said :

you can simply edit file ~/.kde/share/config/digikamrc and remove the line saying MenuBar=Disabled

Revision history for this message
Asoka Dissanayake (adsinky) said :

For me what happens is that when trying to edit a picture, Image Editor does not show the menu bar. In earlier version there was no such problem.

Revision history for this message
dorax (dorien-herremans) said :

Happened to me as well. Opensuse 13.1, kde 4.11.2, digikam.

I removed the MenuBar=Disabled line in ~/.kde4/share/config/digikamrc (slightly different location)

Revision history for this message
mc0e (xgcsufw02) said :

Following advice here, I removed the "MenuBar=Disabled" config line. I was then able to see that the keyboard short-cut for hiding the menu and showing it again is 'ctrl-M', which I could presumably have used in the first place if I'd know it.

I like the way apps like firefox hide the menu behind a small icon if it's hidden, so it's unobtrusive, but still reachable for among other things re-enabling the menu. Perhaps that could be done with digikam?