Ubuntu

Not finding images on digicam.

Asked by TheAJKMan on 2008-07-04

HI there folks. I'm hoping you'll bear with a newb struggling somewhat here. I d/l and installed digiKam via the add/remove packages/programs thing in Ubuntu. The problem I have is that I just can't get the program to see the pics on the camera at all. I clicked Camera -> Add Camera I could select the exact model camera I had no problem. When I click on the Camera - >my didgicam model, I get this error message : "Failed to connect to the camera. Please make sure it is connected properly and turned on. Would you like to try again?" I've tried everything I can think of including getting it to use the default PTP setting and still no luck. Thing is, the exact same camera/cable/USB port work just fine under Windows, so I know the hardware is okay. Help. Please.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu digikam Edit question
Assignee:
No assignee Edit question
Solved by:
TheAJKMan
Solved:
2008-07-04
Last query:
2008-07-04
Last reply:
TheAJKMan (theajkman) said : #1

Okay, one other thing I tried, also without any success is going Camera -> Directory Browse and it gave this error message -> "Failed to list files in /mnt/camera"

AM I missing something obvious like the camera needs to ne mounted first in Linux, if so how do I do that. Please help me guys.

TheAJKMan (theajkman) said : #2

Okay, stumbled across an answer in the archives of the Ubuntu forums. It involved scrolling through the menus till getting to Settings2 and changing it from Auto to PTP. Moment I did that Fspot jumped up and did it's thing on reconnecting the camera to the PC. Hope this helps someone else :)

hooked2u (hooked2u) said : #3

I have the same problem. Camera Kodak Z712 IS selected from list in digiKam. Images won't download. Worked fine with Kodak software and Windows XP. I've erased Windows XP from hard drive; using Ubuntu 8.04 exclusively now. Tried the PTP setting and was able to download a couple images, but all other images not recognized. Digikam worked flawlessly with a previous Kodak camera. Don't understand why not this one. It's in the digikam driver list. Will keep trying.

Ken Walker (kgw) said : #4

I have used digikam a long time and have often had problems with it recognizing a camera to import photos but I discovered a solution that I prefer. I just use the file manager Nautilus that opens automatically when I plug my camera in. I just browse the camera, copy the images and past them into the place I want them in the directory my photos are in. I have a sub folder for each year, and make sub folders named YYYY-MM-DD to put the photos in because I like it that way. When I am done, i can delete them from the camera and unmout it all from nautilus. It all works, it is quick and easy and I have a better idea what it it doing. And I never have to figure out why digikam won't recognize my camera, it always just works. YMMV, might be just me that likes it that way.