Compatability with D300

Asked by elkhelper on 2008-03-01

I am a recent convert to Linux from the evil empire and I really like DigiKam. A free copy of Capture NX came with my new camera and I really do not like it at all; DigiKam has it in spades over the award wining Nikon software. The problem is I haven't been able to work with my raw images from my D300. I have heard that there is an upgrade???? I tried to download a newer version of DigiKam; but haven't figured out how to do it. If there is anyone that can walk me through the install of a newer version or recommend a plugin (and walk me through that install) would be greatly appreciated. I am using DigiKam 0.9.2-final on KDE 3.5.8.
jeff

PS- I have posted questions in other KDE boards, etc. and I don't know what a kernel is, or understand most of the lingo. Linux is a whole different langauge to me. That being the case I would appreciate the Sesame Street explanation.
thanks- jeff

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu digikam Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier
Solved:
2008-03-09
Last query:
2008-03-09
Last reply:
2008-03-05
Olivier (olivier-lacroix) said : #1

Hi !

I am using digikam 9.3 on ubuntu hardy (still unstable) and this version has raw decoding included.

You certainly won't want to upgrade a development version of ubuntu, but you can still install the latest digikam version adding a repository to your list.

open the file /etc/apt/sources.list as root. You can do that entering the following command in a terminal

sudo gedit /etc/apt/sources.list

if you are using kubuntu and not ubuntu, enter instead :

sudo kate /etc/apt/sources.list

add at the end of the file

deb http://www.mpe.mpg.de/~ach/kubuntu/gutsy ./

(I suppose you are using ubutnu gusty, right ? ) save and close. Open your package manager, hit reload, and apply the upgrades.

Tell me if you need more help

Olivier (olivier-lacroix) said : #2

humm. After some though, the library handling raw decoding included in ubuntu gutsy might not support the D300

you may need to install a newer version.

elkhelper (jeff-hostetler) said : #3

Olivier,
I am using Kubuntu latest supported version (gutsy?? i think). I tried what you suggested and I keep getting error messages:

[sudo] password for jeff:
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
Error: "/var/tmp/kdecache-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/ksocket-jeff" is owned by uid 1000 instead of uid 0.
jeff@fred:~$ sudo kate /etc/apt/sources.list debhttp://www.mpe.mpg.de/~ach/kubuntu/gutsy ./
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
Error: "/var/tmp/kdecache-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/ksocket-jeff" is owned by uid 1000 instead of uid 0.
kate: ERROR: : couldn't create slave : Unknown protocol 'debhttp'.
jeff@fred:~$ sudo kate /etc/apt/sources.list
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
Error: "/var/tmp/kdecache-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/ksocket-jeff" is owned by uid 1000 instead of uid 0.
jeff@fred:~$ sudo kate /etc/apt/sources.list deb http://www.mpe.mpg.de/~ach/kubuntu/gutsy ./
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 158
  Major opcode: 146
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
Error: "/var/tmp/kdecache-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-jeff" is owned by uid 1000 instead of uid 0.
Error: "/tmp/ksocket-jeff" is owned by uid 1000 instead of uid 0.
Error: "/var/tmp/kdecache-jeff" is owned by uid 1000 instead of uid 0.
jeff@fred:~$ sudo gedit /etc/apt/sources.list deb http://www.mpe.mpg.de/~ach/kubuntu/gutsy
sudo: gedit: command not found
jeff@fred:~$

When you say download a newer version, are you meaning the newer version of DigiKam? I was told that the latest release of DigiKam is compatible with D300 raw. I simply don't understand how to download and install the newer version. Can you help me with that?
thanks
jeff

Olivier (olivier-lacroix) said : #4

OK. From the commands you typed, I see your have kubuntu and not ubuntu (ir your desktop environment is KDE and not GNOME), and.... that you are totally unaccustomed to the terminal :-)

So, what we are trying to do is open a system file with administrative priviledge, ie as "root".

entering "sudo <command>" executes the specified command as root. So we want to open a text editor. kate is the one coming with Kubuntu. and we provide the path to the file to open to kate. Which gives

sudo kate /etc/apt/sources.list

Sometimes, there are issues with the graphical server preventing from using a graphical application with sudo. This is the case here. In that case, use "kdesu". ENter in a terminal

kdesu kate /etc/apt/sources.list

a graphical prompt shoul appear. Enter your password, and the text editor should appear. copy the line

deb http://www.mpe.mpg.de/~ach/kubuntu/gutsy ./

at the end of the file. Save and close. You added a new source of updates and programs to the list found in the sources.list file.

Now open the adept manager, reload, and upgrade. You should see an upgrade of digikam. Tell me if you don't

Olivier (olivier-lacroix) said : #5

using the terminal can be really powerfull and help is often given as command to copy and paste, because it is easier than explaining where to click. So, having a basic understanding of how it works is usefull. See for instance

https://help.ubuntu.com/community/UsingTheTerminal?action=show&redirect=BasicCommands

Olivier (olivier-lacroix) said : #6

And last but not least, programs under linux do not come in a big block as in windows, but as small bricks depending on one another. For instance, digikam use dcraw to decode raw files. As a result, upgrading digikam may not upgrade dcraw and the support for your camera may be lacking.

elkhelper (jeff-hostetler) said : #7

Olivier,
Thanks for being patient with me (and gentle). I did as you said; but don't quite understand how to reload? There is no option to reload under the menus; I did try "fetch updates" is that the same thing? I did not see a newer version of DigiKam to install. I do have dcraw installed.
Thanks
jeff

Olivier (olivier-lacroix) said : #8

SInce everything is in french on my computer I am not quite sure. Let's do it the terminal way :-)

enter in a terminal

sudo apt-get update

if there are no errors enter the following

sudo apt-get dist-upgrade

if you have errors, copy them here.

Olivier (olivier-lacroix) said : #9

I know that dcraw is installed : it is part of the depencies of digikam (one of the bricks I have been talking about), but the problem may lie in the fact that dcraw is too old, and not digikam...

elkhelper (jeff-hostetler) said : #10

This is what I got:

Get:1 http://security.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://security.ubuntu.com gutsy-security/main Translation-en_US
Get:2 http://us.archive.ubuntu.com gutsy Release.gpg [191B]
Ign http://us.archive.ubuntu.com gutsy/main Translation-en_US
Ign http://security.ubuntu.com gutsy-security/restricted Translation-en_US
Ign http://security.ubuntu.com gutsy-security/universe Translation-en_US
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-en_US
Hit http://security.ubuntu.com gutsy-security Release
Ign http://us.archive.ubuntu.com gutsy/restricted Translation-en_US
Ign http://us.archive.ubuntu.com gutsy/universe Translation-en_US
Ign http://us.archive.ubuntu.com gutsy/multiverse Translation-en_US
Get:3 http://us.archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://us.archive.ubuntu.com gutsy-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com gutsy-updates/restricted Translation-en_US
Hit http://security.ubuntu.com gutsy-security/main Packages
Ign http://us.archive.ubuntu.com gutsy-updates/universe Translation-en_US
Get:4 http://us.archive.ubuntu.com feisty-backports Release.gpg [191B]
Ign http://us.archive.ubuntu.com feisty-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com feisty-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com feisty-backports/universe Translation-en_US
Ign http://us.archive.ubuntu.com feisty-backports/multiverse Translation-en_US
Hit http://security.ubuntu.com gutsy-security/restricted Packages
Hit http://security.ubuntu.com gutsy-security/main Sources
Hit http://security.ubuntu.com gutsy-security/restricted Sources
Hit http://us.archive.ubuntu.com gutsy Release
Hit http://us.archive.ubuntu.com gutsy-updates Release
Hit http://us.archive.ubuntu.com feisty-backports Release
Hit http://security.ubuntu.com gutsy-security/universe Packages
Hit http://security.ubuntu.com gutsy-security/universe Sources
Hit http://security.ubuntu.com gutsy-security/multiverse Packages
Hit http://security.ubuntu.com gutsy-security/multiverse Sources
Hit http://us.archive.ubuntu.com gutsy/main Packages
Hit http://us.archive.ubuntu.com gutsy/restricted Packages
Hit http://us.archive.ubuntu.com gutsy/main Sources
Hit http://us.archive.ubuntu.com gutsy/restricted Sources
Hit http://us.archive.ubuntu.com gutsy/universe Packages
Hit http://us.archive.ubuntu.com gutsy/universe Sources
Hit http://us.archive.ubuntu.com gutsy/multiverse Packages
Hit http://us.archive.ubuntu.com gutsy/multiverse Sources
Hit http://us.archive.ubuntu.com gutsy-updates/main Packages
Hit http://us.archive.ubuntu.com gutsy-updates/restricted Packages
Hit http://us.archive.ubuntu.com gutsy-updates/universe Packages
Hit http://us.archive.ubuntu.com gutsy-updates/main Sources
Hit http://us.archive.ubuntu.com gutsy-updates/restricted Sources
Hit http://us.archive.ubuntu.com feisty-backports/main Packages
Hit http://us.archive.ubuntu.com feisty-backports/restricted Packages
Hit http://us.archive.ubuntu.com feisty-backports/universe Packages
Hit http://us.archive.ubuntu.com feisty-backports/multiverse Packages
Hit http://us.archive.ubuntu.com feisty-backports/main Sources
Hit http://us.archive.ubuntu.com feisty-backports/restricted Sources
Hit http://us.archive.ubuntu.com feisty-backports/universe Sources
Hit http://us.archive.ubuntu.com feisty-backports/multiverse Sources
Fetched 4B in 2s (2B/s)
Failed to fetch http://security.ubuntu.com/ubuntu/dists/gutsy-security/Release Unable to find expected entry deb/source/Sources in Meta-index file (malformed Release file?)
Reading package lists... Done
E: Some index files failed to download, they have been ignored, or old ones used instead.
jeff@fred:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
jeff@fred:~$

Do you live in France or Quebec? What is next? Isn't there a way in the terminal that you can install programs or packages?
Thanks for your help; hope this hasn't turned into a bigger project than you thought..... jeff

Best Olivier (olivier-lacroix) said : #11

Sorry for the delay. From what I see, you have not added the repository line to the soures.list file.

open the famous file :

kdesu kate /etc/apt/sources.list

a text editor window should appear, with lines starting with deb or deb-src

select all, delete all. and copy&paste the following instead

## Binary repositories

deb http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ gutsy partner
deb http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

## Sources repositories

# deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
# deb-src http://security.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
# deb-src http://archive.canonical.com/ubuntu/ gutsy partner

## Digikam
deb http://www.mpe.mpg.de/~ach/kubuntu/gutsy ./

Save and close. Now, enter the following commands in a terminal and put here the various outputs

cat /etc/apt/sources.list

sudo apt-get update

sudo apt-get dist-upgrade

elkhelper (jeff-hostetler) said : #12

Olivier
It worked!!! Thanks so much for your help!!! I really appreciate it. Shoot me an email and I'll send you some pics.
<email address hidden>

thanks again
jeff

Olivier (olivier-lacroix) said : #13

cool !

enjoy digikam, it's a really great phot program !