Printer Selection and Output with Preview

Asked by David Vincent-Jones on 2007-12-28

I have 2 HP printers set in place with HPLIP; both are working correctly.
I have a wide paper HP 8700 for graphics output and
a HP 970 Cxi printer for general service that is/was set as "Default"
Digikam correctly allows me to select the Graphics printer for output
but if I try to use 'gv' to preview the print prior to output only the Default printer is availavle.
I can remedy this by placing the graphics printer as Default but this is a bit of a nuisance.
Is there a work-around for this?

Second question: How do I turn off the 'file-name' being printed? ....



Question information

English Edit question
Ubuntu digikam Edit question
No assignee Edit question
Solved by:
David Vincent-Jones
Last query:
Last reply:
Robert Di Gioia (digioiar) said : #1


In your home directory, there should be a hidden file named .gv
If the .gv file does not exist, you can create it using gv, go to State->GV Options and click Save

Now open the .gv file in your favorite editor...I'll use gedit here from the terminal
gedit ~/.gv

Add a new line at the bottom that says
GV.printCommand: lpr -dyourprintername

substituting the name of your printer for yourprintername. make sure that there is no space between the -d and the printer name. If you don't know the printer name, you can find it on the panel system->administration->Printing

Save the .gv file, and restart gv...when you print you should see your custom print command in the print box, and it should print on your desired printer. I think it will also prevent the file name from printing too.

hope this helps.

David Vincent-Jones (davidvj) said : #2

Found the 'gv' file that already had an entry 'GV.printCommand: lpr' but as proposed I added a new entry at the end of the file 'GV.printCommand: lpr -dPhotosmart_8700'
The name was directly taken from the location that you proposed.

At this point when I tried a "Preview" all I got was a blank screen with the message "Loading ..." in large letters --- Nothing more happened.

I tried to then substitute the new entry for the old statement .... same result

Tried then changing back to the old Default printer setting ... same result

Have tried a reboot ans well as program restarts but I appear to have simply lost the preview capability totally.

Ideas would be appreciated.


Robert Di Gioia (digioiar) said : #3


Did you have to create the .gv file? if so, try deleting the entire file. otherwise you may have to remove and reinstall gv...

David Vincent-Jones (davidvj) said : #4

The problem persists

Something that I should have reported earlier:
When initially I installed 'gv' ( the version that basically worked) it looked very different from 'normal' programs.
There was no title bar, no menus, just a host of buttons (many unlabled) and options to change paper sizes that excluded my paper size.
The window frame was even a different style and color. Despite all that it did in fact work.
As directed it was initially installed with the direct command "sudo apt-get install gv" as you directed.

When I deleted and reinstalled gv I used the Package Manager and then the images failed to load.
This program calls itself "Evince Document Viewer 2.20.1" and is the same program that is being used to display PDFs
Evince D.V. also flashes the word "Loading" prior to showing a PDF

Anyway, I have installed and uninstalled 'gv' several times in several ways.
My correct graphics printer is now showing up correctly (as a part of the installation) in 'gv'

I am including the text of 'gv' ... hope that helps

Thanks for your assistance;

GV.screenSize_david-laptop_0_0:444 x 277
GV.confirmQuit: 0
GV.titleStyle: 0
GV.useBackingPixmap: True
GV.autoCenter: True
GV.scrollingEyeGuide: True
GV.reverseScrolling: False
GV.confirmPrint: True
GV.printCommand: lpr -dPhotoprint_8700
GV.scales: Natural size, 1.000, screen\n\
   Pixel based, 1.000, pixel\n\
   0.100, 0.100\n\
   0.125, 0.125\n\
   0.250, 0.250\n\
   0.500, 0.500\n\
   0.707, 0.707\n\
   1.000, 1.000\n\
   1.414, 1.414\n\
   2.000, 2.000\n\
   4.000, 4.000\n\
   8.000, 8.000\n\
   10.00, 10.00
GV.medias: Letter, 612 792\n\
   # LetterSmall, 612 792\n\
   Legal, 612 1008\n\
   Statement, 396 612\n\
   Tabloid, 792 1224\n\
   Ledger, 1224 792\n\
   Folio, 612 936\n\
   Quarto, 610 780\n\
   # 7x9, 504 648\n\
   # 9x11, 648 792\n\
   # 9x12, 648 864\n\
   # 10x13, 720 936\n\
   10x14, 720 1008\n\
   Executive, 540 720\n\
   # A0, 2384 3370\n\
   # A1, 1684 2384\n\
   # A2, 1191 1684\n\
   A3, 842 1191\n\
   A4, 595 842\n\
   # A4Small, 595 842\n\
   A5, 420 595\n\
   # A6, 297 420\n\
   # A7, 210 297\n\
   # A8, 148 210\n\
   # A9, 105 148\n\
   # A10, 73 105\n\
   # B0, 2920 4127\n\
   # B1, 2064 2920\n\
   # B2, 1460 2064\n\
   # B3, 1032 1460\n\
   B4, 729 1032\n\
   B5, 516 729\n\
   # B6, 363 516\n\
   # B7, 258 363\n\
   # B8, 181 258\n\
   # B9, 127 181\n\
   # B10, 91 127\n\
   # ISOB0, 2835 4008\n\
   # ISOB1, 2004 2835\n\
   # ISOB2, 1417 2004\n\
   # ISOB3, 1001 1417\n\
   # ISOB4, 709 1001\n\
   # ISOB5, 499 709\n\
   # ISOB6, 354 499\n\
   # ISOB7, 249 354\n\
   # ISOB8, 176 249\n\
   # ISOB9, 125 176\n\
   # ISOB10, 88 125\n\
   # C0, 2599 3676\n\
   # C1, 1837 2599\n\
   # C2, 1298 1837\n\
   # C3, 918 1296\n\
   # C4, 649 918\n\
   # C5, 459 649\n\
   # C6, 323 459\n\
   # C7, 230 323\n\
   # DL, 312 624
GV.magMenu: 2, 2\n\
   4, 4\n\
   8, 8\n\
   16, 16\n\
   32, 32\n\
   64, 64
GV.miscMenuEntries: redisplay\n\
   # update\n\

GV.scale: 0
GV.scaleBase: 1
GV.fallbackOrientation: Landscape
GV.orientation: Automatic
GV.fallbackPageMedia: Tabloid
GV.pageMedia: Automatic
GV.swapLandscape: False
GV.autoResize: False
GV.antialias: True
GV.watchFile: True
GV.ignoreEOF: True
GV.respectDSC: True

David Vincent-Jones (davidvj) said : #5

The latest version of HPLIP is now installed and 'preview' is now loading.