Building latest devhelp on ubuntu

Asked by roman

I'm trying to build the latest Devhelp version from source code obtained from the github repository ( on Ubuntu 13.10.
But the configure step fails with the following errors:

configure: error: Package requirements (
  gthread-2.0 >= 2.10.0
  gtk+-3.0 >= 3.9.10
  webkit2gtk-3.0 >= 2.0.0
  gio-2.0 >= 2.37.3
) were not met:

Requested 'gtk+-3.0 >= 3.9.10' but version of GTK+ is 3.8.6
No package 'webkit2gtk-3.0' found

I have the devhelp and libdevhelp-dev ubuntu packages installed but I want to modify the sources (I want to implement the .docset format support).

What should I do to build the latest version on Ubuntu?

Question information

English Edit question
Ubuntu devhelp Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

I think you need to avoid using github in this case.

The description of the package dependencies for devhelp in github has not been updated for 5 years (!!!)

So the installation procedure at github is not reliable or clear (yet) in my humble opinion.

I suggest executing the following commands instead:

sudo apt-get update

sudo apt-get install gnome-common libwebkit2gtk-3.0-dev cdbs dh-translations gnome-pkg-tools libpython3-dev libpython3.3-dev libwebkitgtk-3.0-dev python-scour python3-dev python3.3-dev libgconfmm-2.6-dev

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt-get update

sudo apt-get install devhelp

sudo apt-get build-dep devhelp

sudo apt-get source --compile devhelp

cd devhelp-3.10.2/

Then you should be in the directory containing the source code.

Revision history for this message
roman (romankashicin) said :

Thank you very much for the answer!

I've done the following:
* add gnome3-team repository
* apt-get update and apt-get upgrade
* apt-get build-dep devhelp
* apt-get install libwebkit2gtk-3.0-dev libwebkit2gtk-3.0-25

And now I can build the latest version from the gnome git repository (git:// by running ./ and make:

./src/devhelp --version
Devhelp 3.11.5

Unfortunately, apt-get source devhelp downloads the 3.8.2 version from the main repository, but the git version is better either way.

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

That's not entirely accurate.

apt-get source devhelp downloads the 3.10.2 version AFTER you enable the ppa:gnome3-team/gnome3 and AFTER running the following command:

sudo apt-get update

Take another look at post #1.

I wrote as final command:

cd devhelp-3.10.2/

which refers to version 3.10.2 not version 3.8.2

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

@roman: In any case, we have done very useful work in getting this issue resolved.

Thanks to your useful feedback, I have submitted the following pull request on github:

Pull request is here:

So good job in getting this solved. :-)

Revision history for this message
roman (romankashicin) said :

To #3:
Yep, the apt-get still downloads the 3.8.2 sources even AFTER I perform all the previous steps and have the 3.10.2 version installed and running.

I've just figured out why: the deb-src line were commented out in the
/etc/apt/sources.list.d/gnome3-team-gnome3-saucy.list file.

Thank you for help!