Restore stalls when I reach a certain file

Asked by Philippe Yates on 2013-02-13

I am restoring after a hard disk failure. I had to interrupt the restore and used the resume later button. However, now, whenever I try to restore I reach the file where I had to interrupt and the restore just sits there. It does not seem that one file should take this long. It is a googlemail directory stored through IMAP in thunderbird. .thunderbird/7mwh5o15.default/ImapMail/imap.googlemail.com/Follow up.msf
I thought at first that it was simply a big file and waiting would allow it to be restored, but the restore has been stuck on this file for over an hour.
I have tried restarting the restore and it stalls at the same point.
How can I overcome this problem?
Would wiping the hard drive and reinstalling Ubuntu 12.10 (the program I am using) and then starting the restore again help?
I am trying to restore the files to their original locations. This file is not critical as I can always get it back from google, but other files are very important.
Thanks for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu deja-dup Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Terry
Solved:
2013-02-13
Last query:
2013-02-13
Last reply:
2013-02-13

One more thing, the computer seems to be running very slowly.

Michael Terry (mterry) said : #2

Hrm. I haven't heard of this particular problem before. Try restoring to a fresh directory (instead of choosing "original location"). Then if it finishes restoring, move the files you need to the right places.

Okay, I'm trying that. I'll let you know what happens.

It's been ten minutes on the same file that it got stuck on before. The orange bar shows that some progress has been made (i.e. it has moved further on) but the Details box shows that I am on the same file.
Any other thoughts. Can I get Deja dup to skip that file?

The backup is on an external hard drive which appears to be functioning correctly. I'm copying the backup files to my hard drive to see if a restore from there will be more fruitful.

The file on which it is stuck seems to be pretty small - 1.2KB when restored. So i'm not sure why it would be holding things up.

Best Michael Terry (mterry) said : #7

You can't get it to just directly skip that file, no (unless you resort to manual duplicity console calls -- see [1] for some info about that).

But you can restore around it, sort of. Try using "deja-dup --restore FOLDER" to restore a given folder or file. That should let you get most of the files that don't include the problem one.

[1] https://live.gnome.org/DejaDup/Help/Restore/WorstCase

Do i need to give the complete path or simply name the folder? The information I most want is on the "Documents" folder.

Michael Terry (mterry) said : #9

Either full or relative path is fine.

I have worked this last question out. My immediate problem is now solved. Thanks forthe help. But that does not explain why the complete restore stalled. Anyway, thanks for all your help. I can now restore the filesthat I really need. Which is a great relief.

Thanks Michael Terry, that solved my question.