Alternate Karmic CD does not present the upgrade menu

Asked by Pierre Kerr on 2009-11-14

Binary package hint: debian-installer

I downloaded the alternate CD from http://cdimage.ubuntu.com/daily/current/karmic-alternate-i386.iso. It proceeds to do a normal install. I quite when it starting asking to do partitioning. I found instructions to hit ALT-F2 and run gksu "sh /cdrom/cdromupgrade"

gksu wasn't found. I tried just running th cdromupgrade and it complained about an archive not being found.

My 9.04 installation has something wring with networking so I'm trying this upgrade path.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu debian-installer Edit question
Assignee:
No assignee Edit question
Solved by:
jtniehof
Solved:
2009-11-19
Last query:
2009-11-19
Last reply:
2009-11-15
Best jtniehof (jtniehof) said : #1

Upgrading from the alternate CD should be done by booting into the system that you want to upgrade, not from the CD. Then insert the CD and run the upgrade from there. The instructions here may help:
https://help.ubuntu.com/community/KarmicUpgrades#Upgrading%20Using%20the%20Alternate%20CD/DVD

Pierre Kerr (pkerr) said : #2

I did end up doing the upgrade online after replacing a network card however I have also tried what you have suggested. When I put the CD in my drive it gets mounted to /media/cdrom0 and so the command gksu "sh /cdrom/cdromupgrade" wasn't happy. I re-mounted the CD to /cdrom and after a page or so of ugly messages (see below) it started the upgrade.

Thank you for your quick response and I apoligize for my slow reply.

---------- message after sending gksu "sh /cdrom/cdromupgrade" ---- I was connected to the internet and this is exactly how the message appeared in my terminal session - no returns..

  root@huey:/cdrom# gksu "sh /cdrom/cdromupgrade"
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

(gksu:5580): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
gpgv: Signature made Tue 27 Oct 2009 01:19:01 PM EDT using DSA key ID FBB75451
gpgv: Good signature from "Ubuntu CD Image Automatic Signing Key <email address hidden>"

jtniehof (jtniehof) said : #3

Ah, gksu shouldn't be run as root, but as your normal user. That would be why you got the error messages.
Thanks for the catch on the mount point for the CD. I've updated the wiki page to fix that.