WPA Passphrase

Asked by Michael Weichert on 2007-04-04

Is there anyway possible to configure a wireless card with a WPA-Personal passphrase from the debian-installer?

I'm kickstarting an installation, and doing lots of work in the postinstall script that relies on the Internet. My problem is that I only have access to a wireless network. I tried using the Ubuntu Reconstructor to add wpasupplicant but that didn't seem to work.

Thanks,
Mike

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu debian-installer Edit question
Assignee:
No assignee Edit question
Last query:
2007-04-09
Last reply:
2007-04-10
Joel Garske (joel-garske) said : #1

if you have a valid and running wpa_supplicant in the installer, you should be able to bring up the wireless interface durung installation manually (using one of the consoles provided). Then try "Leaving the Network unconfigured" or, if it still exists, manual non installer based configuration of the card.

If that doesn't work, please providefurther information about the error, the wpa_supplicant you are using, the card in your wireless station, the installation kernel, loaded modules, wpa_supplicant invocation and anything else you think would be nice to know. I'll try to reproduce the scenario as far as possible then, this afternoon.

Greetings,
     Joel Garske

Hi Joel,

Thank you very much for your help.

Installation kernel: 2.6.17-10-386
Wireless card: madwifi

When I execute the following:

wpa_supplicant -D madwifi -i ath0 -c /etc/wpa_supplicant.conf -w

I get the following:

ioctl[SIOCSIWPMKSA]: Operation not supported
Trying to associate with 00:0f:66:19:6e:33 (SSID='fd' freq=2462 Mhz)
ioctl[IEEE80211_IOCTL_SETMLME]: Argument list too long
Association request to the driver failed
Authentication with 00:00:00:00:00:00 timed out.

Joel Garske (joel-garske) said : #3

First of all, thank you for your information

what happens, when you try to use -Dwext instead of -Dmadwifi? (try leaving out the " " between option and argument... wpa_supplicant will like you much more.

the wext thing is, because i came across a document some time ago, telling, that madwifi also supports the linux wext now (i think since madwifi-ng). Its worth a try. Tomorrow there will be further investigation on this problem.

see you nd best regards,

          Joel Garske

Hi Joel,

Sorry I didn't get back in touch with you till now. I hope you had a Happy Easter.

You are the greatest - using Dwext fixed the problem.

Just one more question. If wpa_supplicant is having a hard time trying to connect to the wireless network (because of signal strength) will it eventually timeout?

Thanks,
Mike

Spoke too soon...sorta. ;)

When kickstarting, I thought I'd use the preinstall script to use wpa_supplicant - but the interfaces are not yet available at this stage of the installation. Is there anyway I can run the wpa_supplicant command at a given point in the installation, or will I have to wait and run the command in the postinstall script?

Thanks,
Mike

Okay, I moved things to a postinstall script that is like the following:
- Run wpa_supplicant command
- dhclient ath0
- perform commands that require internet connection

However, the wpa_supplicant command doesn't return control to the console after it establishes a connection, and therefore my installation "hangs". Any ideas of how to get around this?

I feel we're soo close!

Thanks,
Mike

Joel Garske (joel-garske) said : #7

yes, theres a switch in WPA supplicant that makes it run in daemon mode.... Its -B, maybe you try it :)

Greetings, Joel

Can you help with this problem?

Provide an answer of your own, or ask Michael Weichert for more information if necessary.

To post a message you must log in.