Dapper: installation failure in debconfig

Asked by Cuebee on 2008-10-06

Binary package hint: debconf

I failed to upgrade from dapper to hardy, then try to reinstall dapper. After modified the /etc/apt/sources.list and all the good apt-get stuff... I got this message:

Reading package lists...
Building dependency tree...
debconf is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up hwtest (0.1-0ubuntu10) ...
Traceback (most recent call last):
  File "/usr/share/hwtest/install/config", line 13, in <module>
    from debconf import Debconf, DebconfCommunicator
ImportError: No module named debconf
dpkg: error processing hwtest (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of hwtest-gtk:
 hwtest-gtk depends on hwtest; however:
  Package hwtest is not configured yet.
dpkg: error processing hwtest-gtk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on hwtest-gtk; however:
  Package hwtest-gtk is not configured yet.
dpkg: error processing ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 hwtest
 hwtest-gtk
 ubuntu-desktop

I have manually sudo dpkg-reconfigure debconf, answer a couple question the program prompted me, then reinstall the debconf -- STILL FAILED at the same point. I am not sure this is my system's env problem or the debconf has change name/link for import???
If this is not a bug, please post it to the community forum as a problem.

Thanks!

Cuebee

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu debconf Edit question
Assignee:
No assignee Edit question
Solved by:
Cuebee
Solved:
2008-10-17
Last query:
2008-10-17
Last reply:
2008-10-07

This question was originally filed as bug #279355.

Cuebee (huiyen-hung) said : #1

Dapper has been sucessfully installed before, and work as a production's backend, so I think this may be just some env variable missing or system config file missing. On the other hand, it may due to the debconf developing team has changed in the last two years??? Anybody knows the answer, please kindly post an answer. Thanks!

Bhavani Shankar (bhavi) said : #2

If you open up a terminal window (Applications/Accessories/Terminal) and type "sudo apt-get update" and "sudo apt-get upgrade" without the quotes, what response do you get?

Cuebee (huiyen-hung) said : #3

<sudo apt-get update> downloads all the updatable files listed in my
/etc/apt/sources.list(which is orignially dapper then change to hardy). and
<sudo apt-get upgrade> got the responses something like "17xxx packages
available, 15xx files install 4 broken lindexes.... This version of dapper
is not upgradable to hardy..." But I can't wait for the answer, I have a
production goes on to maintain. So I reinstall the dapper and reinstall the
developing environment (Ruby on Rails)... now I have unconfigurable version
of RoR on dapper...My major problem is <hwtest> and its related files. This
resulted in 1.) a File Browser that each time I clicks on any folder, it
pops up my home folder -- every click opens the same home folder...2.) Ruby,
gem, capistrano, and rails all incompatible after installing each and
prompted for upgrading.... It's a mess now, I really don't know how to
address my misseries...Any idea? Great Thanks!

Cuebee

On Tue, Oct 7, 2008 at 5:07 AM, Bhavani Shankar <
<email address hidden>> wrote:

> Your question #47312 on debconf in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/debconf/+question/47312
>
> Status: Open => Needs information
>
> Bhavani Shankar requested for more information:
> If you open up a terminal window (Applications/Accessories/Terminal) and
> type "sudo apt-get update" and "sudo apt-get upgrade" without the
> quotes, what response do you get?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.edge.launchpad.net/ubuntu/+source/debconf/+question/47312
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Cuebee (huiyen-hung) said : #4

The problem has been solved. It was a "downward compatibility" issue in libnautilus-extension1 package. My Dapper originally has python2.4.2 base, then upgraged to phthon2.5.2 base, that changes a lot of supporting package, including gnome-control-center and nautilus file manager, ruby and all ruby related gems. I have to reinstall all my project related gems back to the old version and down grade many supporting packages. I mostly used "sudo aptitude -s -vv xxxxxxxxxx" for advice, and I was able to get my project running both on my developing machine and remoted production machine. Sorry to bug you guys online...and Thank you for sharing my frustrations...

Cuebee