Ubuntu 12.04; dash cannot search out programs

Asked by nathan JNX on 2012-05-03

untu 12.04; dash cannot search out programs, only files can be searched. what up? Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu dash Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-05-09
Last query:
2012-05-09
Last reply:
2012-05-08

This question was reopened

Did you upgrade, or is it a clean install?

Thanks

nathan JNX (chemie) said : #2

I installed Ubuntu 12.04 by live-USB drive, DVD-64bit version; it is a clean install I think.
I found actually it can only search out songs, even pdf and documents cannot be found; I click the icon of "home", I think it mean all files, and the next icon means programs i think.

Barry Drake (b-drake) said : #3

On the Dash click the applications icon (the one that looks like a ruler and two candles) at the bottom of the Dash. This will specifically search for apps. You can use the filter results item at the top left to make this easier if you want. If that doesn't work please get back to us.

nathan JNX (chemie) said : #4

Thank you, however it doesn't work.
It worked well when I run live-CD session. I don't know what' wrong now.

nathan JNX (chemie) said : #5

Thank you, however it doesn't work.
It worked well when I run live-CD session. I don't know what' wrong now.

ob Hotchkiss (bhotchkiss) said : #6

I am having a similar problem. I just updated from 11.10 to 12.04, and now my dash only finds files, and not many of those. Applications are not visible at all. I have all necessary permissions, but can no longer see any applications at all.

nathan JNX (chemie) said : #7

Any solution for it? thanks.
How to run applications from "Ubuntu software center"? or anywhere else to run an application?

nathan JNX (chemie) said : #8

Same here. After upgrading from 11.04 to 11.10 to 12.04 (beta2) the DASH menu doesn't list any applications. Previously typing "calc" for example would list the calculator and LibreOffice Calc. Now, nothing shows up, neither in the main DASH window, nor in the application lens.

However, in the main lens songs (FLAC) do show up, but for instance documents don't. Furthermore, I have regular crashes of unity-lens-video. Apport told me this problem had already been reported. Maybe this is related?

Looking a bit closer in ~/.xsession-errors I found that the zeitgeist daemon crashed:

(zeitgeist-datahub:2329): LibZeitgeist-CRITICAL **: Unable to connect to Zeitgeist daemon: Error calling StartServiceByName for org.gnome.zeitgeist.Engine: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/zeitgeist-daemon exited with status 1

According to https://bugs.launchpad.net/ubuntu/+source/zeitgeist/+bug/986191 this happens when upgrading from Ubuntu 11.04 to 12.04. Removing ~/.local/share/zeitgeist/activity.sqlite solves the problem.

Barry Drake (b-drake) said : #9

Everything described here points to a faulty upgrade. A clean install never shows these problems. You can have a go at fixing them; there are a whole lot of terminal commands that we could suggest. At the end of the day you will probably find you are going to be wiping everything and doing a clean install. You will save a lot of time and trouble doing this.

try:

mv ~/.local/share/zeitgeist/activity.sqlite ~/.local/share/zeitgeist/activity.sqlite_old

Then reboot

HTH

nathan JNX (chemie) said : #11

Thanks actionparsnip, that solved my question.

Jeff Gitter (gitter1226) said : #12

None of these solutions worked for me. I upgraded in April when 12.04 was released and didn't have problems until a week or two ago. I don't see any zeitgeist crashes and removing or renaming that folder has no effect. Any other ideas?