cupsys 1.2.11-1ubuntu1 source package in Ubuntu

Changelog

cupsys (1.2.11-1ubuntu1) gutsy; urgency=low

  * Synchronize to Debian; remaining Ubuntu changes:
    - Snakeoil SSL cert support:
      + debian/control: Add ssl-cert dependency.
      + debian/cupsys.postinst: Symlink snakeoil SSL certificate if present.
      + debian/cupsys.preinst: Fix global SSL certificate owner/mode breakage
        (see 1.2.1-2ubuntu2); this needs to be kept until the next LTS
        release.
    - TearDown (fast shutdown):
      + debian/control: Add sysv-rc (>= 2.86.ds1-14.1ubuntu2) dependency.
      + debian/cupsys.postinst: Remove obsolete rc.d links.
      + debian/rules: Use 'multiuser' update-rc.d mode.
    - debian/control: Drop cupsys-dbg.
    - debian/cupsys.{config,postinst}: Transition to enable additional
      backends on upgrades. Needs to be kept until next LTS release.
    - debian/patches/ubuntu-default-error-policy-retry-job.dpatch: Retry a
      failed job instead of stopping the print queue.
    - debian/patches/ubuntu-disable-browsing.dpatch: Disable browsing by
      default.
  * Drop patches which are upstream now:
    - 80_brother_no_backchannel.dpatch
    - 92_texttops-prettyprint-crash.dpatch
    - 94_doc-port-in-client-conf.dpatch
    - 96_more-bug-fixes-between-cups-1.2.8-1.2.9.dpatch
    - 90_testpage-on-large-paper-sizes.dpatch

cupsys (1.2.11-1) unstable; urgency=low

  [ Kenshi Muto ]
  * Applied templates improvement patch contributed by
    debian-l10n-english team. (closes: #416350)
  * Debconf translation
    - Japanese
    - Galician (closes: #416357)
    - Swedish (closes: #416356)
    - Catalan (closes: #416367)
    - Basque (closes: #416385)
    - Norwegian (closes: #416401)
    - Italian (closes: #416407)
  * New upstream version 1.2.11:
    - 56_dirsvc patch is merged.

  [ Christian Perrier ]
  * Debconf translation
    - Czech (closes: #416939)
    - German (closes: #416994)
    - Brazilian Portuguese (closes: #417249)
    - French
    - Malayalam. (closes: #418030)
    - Russian. (closes: #417874)
    - Dutch. (closes: #418135)
    - Portuguese (closes: #418299)

  [ Martin Pitt ]
  * New upstream bugfix release (closes: #421899).

  Synchronize patches with Ubuntu and new upstream version 1.2.10:

  * Drop patches which are fixed upstream:
    00_00str2111.dpatch, 00_01str2137.dpatch, 00_02str2144.dpatch,
    00_03str2106.dpatch, 00_04str2117.dpatch, 00_05str2133.dpatch,
    00_06str2121.dpatch, 00_07str2123.dpatch, 00_08str2135.dpatch,
    00_09str2198.dpatch, 03_clean.dpatch, 65_detect_http_shutdown.dpatch
  * Remove a few obsolete patches:
    08_cupsd.conf.conf.d.dpatch, 26_modprobe.dpatch, 48_stdlib.dpatch,
    61_job_c_strangeloop.dpatch, 08_cupsd.conf.conf.d.dpatch,
    64_driverfolder.dpatch.
  * Add debian/patches/14_dont_force_ssl.dpatch: Do not require SSL for /admin
    pages, since gnome-cups-manager (and most probably other GUI frontends)
    does not support this.
  * Add debian/patches/58_cupsd.conf-AllowLocal.dpatch: Allow access to local
    ethernet by default. This just affects the ACL, for actually enabling
    access cupsd needs to be switched to not only listen on localhost. With
    that, this setting does not need to be configured in two different places.
  * Add debian/patches/70_reactivate_recommended_driver.dpatch: Upstream CUPS
    filters the "(recommended)" marking from the NickNames of the PPD files
    when listing PPDs. These are an important orientation for the user and
    they are also made use of by some printer setup tools. We need them at
    least until a better solution for recommending drivers gets available.
  * Add debian/patches/98_search_mime_files_in_usr_share.dpatch: Let CUPS also
    search for *.types and *.convs files in /usr/share/cups/mime. This way
    packages can provide *.types and *.convs files which do not get considered
    as conffiles. (See https://launchpad.net/36532 for details).
  * debian/patches/*.dpatch: Forwarded a lot of patches to upstream bug
    tracker, add STR URLs to dpatch DP: headers.

  Synchronize packaging with Ubuntu:

  * debian/control: Drop transitional libcupsys2-gnutls10 package, it was only
    required for Sarge->Etch upgrades.
  * debian/control: Change netbase dependency to update-inetd, since that
    lives in its own package now.
  * debian/local/enable_sharing: Also match on 127.0.0.1 IP adresses in
    addition to 'localhost'.
  * debian/rules: Most of the clean:: rule is obsolete, only two files are
    left behind now. These two have been reported upstream in
    http://www.cups.org/str.php?L2366.
  * debian/cupsys.templates: Activate SCSI, serial, and SNMP backends by
    default. With these backends activated, many printers can be easily set up
    with the printer setup tools.  Especially network printers get
    auto-detected and the correct URI gets assigned to them (doing this
    manually is a non-trivial task for most users).
  * debian/cupsys.dirs: Add /usr/share/ppd/custom/, a place where lpadmins can
    store additional PPDs (this functionality is e. g. provided in
    gnome-cups-manager's "Custom driver..." file dialog).
  * debian/cupsys.init.d: Give proper permissions to /usr/share/ppd/custom/:
    root:lpadmin 3775. Drop the obsolete chmod/chowning of
    /usr/share/cups/model.
  * Run the backend as non-root system user to confine the impact of security
    vulnerabilities:
    - Add debian/patches/10_external_pam_helper.dpatch:
      + Add a helper program 'cups-check-pam-auth' which performs PAM
        authentication and returns the status as exit code.
      + scheduler/auth.c, cupsdAuthorize(): Attempt to use
        cups-check-pam-auth before trying native PAM.
      + With this we do not need to put the cupsys user into the shadow group.
    - debian/cupsys.files: Install PAM helper.
    - debian/cupsys.postinst: Set permissions of PAM helper to cupsys:shadow
      2754, alter permissions of some configuration files and directories to
      work with non-root cupsd.
    - debian/cupsys.postinst: Fix /var/cache/cups/ permissions for upgrades
      which might have written cache files as root.
    - debian/cupsys.logrotate: Save log files as cupsys:lpadmin.
    - debian/cupsys.init.d: Disable 'reload'; change force-reload to restart,
      since cupsd cannot reload as non-root.
    - debian/cupsys.init.d: Set up proper permissions of log files.
    - debian/rules: Enable --enable-privilege-dropping configure option.
    - debian/rules: Install lpd backend suid root, so that it can bind to
      ports < 1024 (really silly, but required for RFC compliance).
    - debian/cupsys-client.postinst, debian/cupsys.postinst: Set up cupsys
      system user.
  * debian/NEWS: Describe derooting.

 -- Martin Pitt <email address hidden>   Mon, 14 May 2007 11:07:42 +0200

Upload details

Uploaded by:
Martin Pitt on 2007-05-14
Uploaded to:
Gutsy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
net
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
cupsys_1.2.11.orig.tar.gz 4.2 MiB ef12b16915b9e79a8e7368610aa50d3413ab94bbe81c571af63dd1c03b35d874
cupsys_1.2.11-1ubuntu1.diff.gz 113.0 KiB 150024e987a496eb0b50dea461a6864e79b0e76b9b0b9a9cbdfd411e311fd925
cupsys_1.2.11-1ubuntu1.dsc 1.1 KiB d855ff5d4fa528ea8db4a79d3838f3bd379903c607dc60a68e419e6d45d08057

View changes file

Binary packages built by this source

cupsys: No summary available for cupsys in ubuntu gutsy.

No description available for cupsys in ubuntu gutsy.

cupsys-bsd: No summary available for cupsys-bsd in ubuntu gutsy.

No description available for cupsys-bsd in ubuntu gutsy.

cupsys-client: No summary available for cupsys-client in ubuntu gutsy.

No description available for cupsys-client in ubuntu gutsy.

cupsys-common: No summary available for cupsys-common in ubuntu gutsy.

No description available for cupsys-common in ubuntu gutsy.

libcupsimage2: No summary available for libcupsimage2 in ubuntu gutsy.

No description available for libcupsimage2 in ubuntu gutsy.

libcupsimage2-dev: No summary available for libcupsimage2-dev in ubuntu gutsy.

No description available for libcupsimage2-dev in ubuntu gutsy.

libcupsys2: No summary available for libcupsys2 in ubuntu gutsy.

No description available for libcupsys2 in ubuntu gutsy.

libcupsys2-dev: No summary available for libcupsys2-dev in ubuntu gutsy.

No description available for libcupsys2-dev in ubuntu gutsy.