Package in bad inconsistent state

Asked by ashok on 2008-12-11

After trouble with installing updates, tried "sudo-- configure-a and got the following:

ashok@newdell:~$ sudo dpkg --configure -a
dpkg: error processing cupsys (--configure):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting configuration.
Errors were encountered while processing:
 cupsys
ashok@newdell:~$

Please advise. Do I have to make a new CD of Ubuntu and reinstall? Please let me know the simplest procedure for doing that. Many thanks.

Ashok
<email address hidden>

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cupsys Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-12-13
Last query:
2008-12-13
Last reply:
2008-12-12
Sam_ (and-sam) said : #1

Hi,
if you have nothing to lose and made anyway a complete new installation, you may check if the CD was burned correct, at best not too fast.
It might be better to use the Alternate CD for installation.

Or you try to fix it on current installation with:
sudo apt-get -f install

https://help.ubuntu.com/community/AptGet/Howto

Seems like this https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/26404

Please open a Terminal from the menu Applications->Accessories->Terminal and type or copy and paste the row below:

sudo apt-get --reinstall install cupsys
sudo dpkg --configure -a
sudo apt-get -f install

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

ashok (athadani) said : #3

Thank you very much, that solved the problem.

All the best to contributors.

Ashok