xerox usb printer not recognized

Asked by Seletech on 2010-01-29

My problem seems very near to the one described on the question:

Brother HL-2140 USB printer not recognized in printer set up in Ubuntu 9.10 alpha 4 (Solved)
posted on 2009-08-30 by garvinrick4, answered by garvinrick4 in “cups” package in Ubuntu

Anyway the Garvinrick4 resolution doesn't seem to solve the question.
We are trying to connect a Xerox Phaser 6140 via usb to our Ubuntu Karmic 9.10 x86_64 linux box
(Linux 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 17:01:44 UTC 2009 x86_64 GNU/Linux).
The same printer works fine when connected via lan, but we need it working via usb ...
The same hardware works fine when booted as Windows XP.
I tried to apply the suggested solution of Garvin but it seems to give worse results, so I returned to the original state.
I suppose (may be I'm wrong) that the Garvin fixing has been already included in the current Karmic
Here is what I can see:

When we insert the usb connector, the /var/log/message records:

Jan 29 17:32:45 spvi-client3 kernel: [ 7152.187481] usb 2-1.7: new high speed USB device using ehci_hcd and address 5
Jan 29 17:32:45 spvi-client3 kernel: [ 7152.300670] usb 2-1.7: configuration #1 chosen from 1 choice
Jan 29 17:32:45 spvi-client3 kernel: [ 7152.301861] usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x0924 pid 0x3D65
Jan 29 17:32:46 spvi-client3 kernel: [ 7153.331326] usb 2-1.7: usbfs: interface 0 claimed by usblp while 'usb' sets config #1

the command lsusb reports:
...
Bus 002 Device 005: ID 0924:3d65 Xerox
....

the command "lsmod | grep usb" gives:

usblp 15136 0
usbhid 43968 0

while in /var/log/cups/error_log we have:

E [29/Jan/2010:17:32:46 +0100] [cups-deviced] Bad line from "usb": direct usb://Xerox/Phaser%206140N "Xerox Phaser 6140N" "Xerox Phaser 6140N" "MFG:Xerox;CMD:PJL,RASTER,DOWNLOAD,PCLXL,PCL,HBPL,POSTSCRIPT;MDL:Phaser 6140N;DES:Xerox Phaser 6140N;CLS:PRINTER;STS:AAAQBAD/AP8AAAAAAAgAA2QDZANkA2QDZANkA2QDQBoAAAAAsIYAAAAAAAAAAAAA4AAAEAAAAAAQ
E [29/Jan/2010:17:32:46 +0100] [cups-deviced] Bad line from "usb": DA==;" ""
W [29/Jan/2010:17:32:46 +0100] [CGI] Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect

reported twice.
I suppose that this means that cups can see that the new device has been attached and that it is able to try to understand how to handle it.
Looking at the error strings, I have seen that the bad lines were missing of their closing quote ".
Thus, I tried a substitute for the usb backend (/usr/lib/cups/backend/usb) that filtered the output of the real usb backend appending the missing closing quote.
This way, the execution of /usr/lib/cups/backend/usb gives the following output:

direct usb://Xerox/Phaser%206140N "Xerox Phaser 6140N" "Xerox Phaser 6140N" "MFG:Xerox;CMD:PJL,RASTER,DOWNLOAD,PCLXL,PCL,HBPL,POSTSCRIPT;MDL:Phaser 6140N;DES:Xerox Phaser 6140N;CLS:PRINTER;STS:AAAQBAD/AP8AAAAAAAgAA2QDZANkA2QDZANkA2QDQBoAAAAAsIYAAAAAAAAAAAAA4AAAEAAAAAAQ"
DA==;" """

Anyway, with this patch the problem is not solved, because in the error_log is still reported the following error:

W [29/Jan/2010:17:40:60 +0100] [CGI] Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect

I haven't been able to understand what is the reason for this error, thus I returned to the original usb backend.

The result to the command "lpinfo -vv" is always the same (no matter if with the patch or not):
           direct scsi
           file cups-pdf:/
           network ipp
           network http
           network smb
           network beh
           direct hp
           network socket
           network lpd
           direct hpfax
          network dnssd://Xerox%20Phaser%206140N%20(c3%3A07%3Aa5)._printer._tcp.local/
          network dnssd://Xerox%20Phaser%206140N%20(c3%3A07%3Aa5)._ipp._tcp.local/
          network dnssd://Xerox%20Phaser%206140N%20(c3%3A07%3Aa5)._pdl-datastream._tcp.local/
          network lp

where you can see that the networked interface is well recognized while the "direct usb" is completely missing.

I the other log file (/var/log/cups/access_log) each "lpinfo -v" request records:

localhost - - [29/Jan/2010:17:59:17 +0100] "POST / HTTP/1.1" 401 75 CUPS-Get-Devices successful-ok
localhost - root [29/Jan/2010:17:59:17 +0100] "POST / HTTP/1.1" 200 2554 CUPS-Get-Devices -

Well.... Is there someone that can help me?
Thank you.
                    Savino

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2010-02-25
Last reply:
2010-02-14
Seletech (s-rapillo) said : #1

Hello,
just to know, is there hope to have any help? Is there anythink I can do to explain better what's up?
Is it a bug? and if yes is it a cups bug or a xerox driver bug?
Please help me to understand where do I look to find a solution.
Thank you

p.s.: if this is not the right site or the right way to look for a help, please let me know.

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Seletech (s-rapillo) said : #3

Sorry, but I still need an answer

Can you help with this problem?

Provide an answer of your own, or ask Seletech for more information if necessary.

To post a message you must log in.