Trying to get printer working

Asked by Rich Gardner on 2020-04-23

Have a Canon Pixma TR8520. Worked as a remote wireless printer while using latest version of Windows. Stopped working for no discernable reason (no error message, it just wouldn't work). Hadn't used it in a while, so figured it needs to be connected by an actual wire. Sure enough, it has a port in back for a wire, so I hooked that up. Downloaded the appropriate driver from Canon and expanded it in the Downloads folder. When I press "print," the computer says it's printing, but the printer doesn't print anything. i'm hoping there's just a step r two I haven't completed yet.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Rich Gardner
Solved:
2020-04-28
Last query:
2020-04-28
Last reply:
2020-04-24

This question was reopened

When you send a print job does it show in the print queue OK?
Are there any messages there?
Can you print a test page from the printer itself?
Can you ping the printer's IP address OK?

Rich Gardner (rlg3526) said : #2

1. Yes.
2. Yes, says everything is fine.
3. Routine runs through and reports that test page printed fine, but nothing gets printed.
4. Am puzzling out how to find the printer's IP address.

Rich Gardner (rlg3526) said : #3

When I pinged DE1F28000000 using Windows, I got
Ping request could not find host.
When I pinged 9100, I got
Pinging 0.0.35.140 General failure

Using Linux, I got Name or service not known, invalid argument and invalid argument.

Rich Gardner (rlg3526) said : #4

Woo hoo! I had re-started the computer during the process, but I didn't have the printer on at the time. Re-booted the computer while the printer was on. It works now!

shan (hsansed99) said : #5

Hey, I'm also facing the same problem in my deivce. Some post have the solutoin like this https://answers.launchpad.net/ubuntu/+question/690099
I have applied this in my website here https://themitersaw.com/