Issues with CUPS on Ubuntu 14.04

Asked by S Michael Smith on 2018-08-03

I recently performed a general update; cups was bumped from 1.7.2-0ubuntu1.9 to 1.7.2-0ubuntu1.10. I'm not positive this was the cause, but I can no longer print *any* documents to my Canon MX922 network printer, whereas before, it worked correctly. I can still print PDFs, and I can send a proper test page from the CUPS interface, but no other application will print, or in a few cases, print correctly. Those docs that actually reach the printer are fragmented and of odd color, formatting, etc. (the printer works fine, including from a second Ubuntu 14.04 machine that still has the 1.9 version of CUPS, and a Windows 10 machine).

I'm at a loss how to trouble-shoot this, roll it back, or otherwise make it work again. Any suggestions what I might try? Forcing version/build 1.9 does not seem to be possible.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2018-08-03
Last reply:
2018-08-03

For example, if I print the cupsd.conf text file from a text editor on this (CUPS 1.7.2-0ubuntu1.10) Ubuntu 14.04 machine, I can see a print-preview screen, and it looks correct. But when I actually send it to the printer, the text is in light green rather than normal black, and it appears oddly enlarged, as if only a small viewport version of the file is printed (margins, spacing, etc., are incorrect, and numerous pages are dumped, some blank, others with a single text line.

I can print the same file on the second Ubuntu 14.04 machine, with earlier CUPS build, perfectly.

If you remove the driver (if you installed one), delete the printer from Ubuntu, turn off the printer and reboot. Log in and turn on the printer and re-setup the printer again does it help

Thanks, not completely sure what you suggest. Remember, it is a network printer (not attached to this machine). I deleted the printer in the System Settings area, rebooted Ubuntu, and tried again. No change in results, but it's not clear if the old printer profile got reused. It did seem to find the printer on the network, but shows its address as "localhost", which should be incorrect, unless it's seeing it as a local presence through a daemon.

I don't remember ever installing a special driver, but may have forgotten.

Can you help with this problem?

Provide an answer of your own, or ask S Michael Smith for more information if necessary.

To post a message you must log in.