cups client error document format not supported during installation of printer: Brother 240MFC

Asked by anilmani on 2009-03-21

I am not able to print a test page from HP Laserjet 1020.
I get error - CUPS: client-error-document-format-not-supported.

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2009-04-17
Last query:
2009-04-17
Last reply:
2009-03-24

Your printer seems to works perfectly http://openprinting.org/show_printer.cgi?recnum=Brother-MFC-240C

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(if the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

sudo gedit /etc/cups/mime.convs
change the very bottom row in that file removing the "#" char at the start of the line so change:

#application/octet-stream ....

to

application/octet-stream

Save and exit editing.

Then open the file:

sudo gedit /etc/cups/mime.types

go to the end of file and verify there is a line like this

application/octet-stream

with no any "#" char at row start. If there is any please simply delete the "#" char and then save and exit.

Then please restart cups server on your pc using a terminal type:

sudo /etc/init.d/cups restart

(if the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

Then retry.

------------------------------------------------------------------

As newbie, this might help you (see printing section): https://help.ubuntu.com/8.10/index.html
As a starting point you can browse and search under https://answers.launchpad.net/ubuntu/+source/cups

Hope this help

anilmani (kurianmani) said : #2

Hello marcobra,

First of all, thank you for the immediate reply. I did exactly those steps. Edited those lines, saved them and tried printing . But the error message remains the same.

Please also check if the printer works even it don't print the test page... by print a document.

Then if don't print please remove the printer...

Then please try to install the deb package coming from brother site:
http://solutions.brother.com/linux/en_us/download_prn.html

Download the cupswrapper driver and save to disk.
http://solutions.brother.com/linux/en_us/download_prn.html#MFC-240C

Then read this instructions: http://solutions.brother.com/linux/en_us/before.html#002

in short using terminal you must type:

sudo aa-complain cupsd
sudo mkdir /usr/share/cups/model

Then to install the .deb package type:

sudo dpkg -i mfc240ccupswrapper-1.0.1-1.i386.deb

Then retry...

Thank you

anilmani (kurianmani) said : #4

Looks like I may have some conflict issues:

This is the terminal/Screen output while I try installing mfc240clpr-1.0.1-1.i386.deb

brother-lpr-drivers-bh7 conflicts with mfc240clpr

it also says:

conflicting packages - not installing mfc240clpr

Is there any way to remove this conflicting version?

Thanks for the time you dedicate for me.

Anil

Please try to remove the package brother-lpr-drivers-bh7 using a terminal type:

sudo apt-get remove brother-lpr-drivers-bh7

Then retry to install the mfc240ccupswrapper-1.0.1-1.i386.deb

sudo dpkg -i mfc240ccupswrapper-1.0.1-1.i386.deb

Hope this helps

anilmani (kurianmani) said : #6

Hello Marcobra...

Thanks.. That solved my problem.

Great.... I really appreciate your help.

Anil

anilmani (kurianmani) said : #7

Thanks marcobra, that solved my question.