Cups deleted, won't re-install

Asked by Mark Parker on 2017-03-28

A recent update crashed with a comment about cups not upgrading properly, something about unresolved dependencies. I think it is related to a known bug. Anyway I did "apt update" and then tried the Ubuntu Software Updater again. It said it could do a "partial upgrade" as not all of the previous upgrade had completed properly. I was a bit concerned about "upgrade" vs. "update" but i told it to go. IT DELELTED ALL OF CUPS! When I try to re-install cups with software center, I get: PAckage Dependencies Cannot be Resolved This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time. I tried "sudo apt-get install cups" and get:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cups : Depends: libcups2 (= 2.1.3-4) but 2.1.3-4ubuntu0.2 is to be installed
        Depends: cups-core-drivers (>= 2.1.3-4) but it is not going to be installed
        Depends: cups-daemon (>= 2.1.3-4) but it is not going to be installed
        Recommends: printer-driver-gutenprint but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And, of course nothing related to printing/scanning/etc. works. HELP!!!

Question information

English Edit question
Ubuntu cups Edit question
No assignee Edit question
Solved by:
Mark Parker
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the commands

uname -a
lsb_release -crid
cat /etc/apt/sources.list
apt-cache policy cups libcups2

Cause of your problem might be that you had the xenial-proposed repository enabled once, but it is no more enabled now.

Manfred Hampl (m-hampl) said : #2

I just saw that your problem probably is related to bug #1676380 and the removal of cups version 2.1.3-4ubuntu0.2 which was in xenial-updates.

Mark Parker (dmtparker) said : #3

Well, it is VERY inelegant, but I solved the problem by upgrading to 16.10. Normally I stick with LTS, but there were a variety of other minor issues with 16.04 that I felt it worth the upgrade. Now everything is working fine. I know this is a terrible way to solve such a problem, but I needed the printer NOW and, as I said, I had other issues with16.04 (like it kept losing my background and screen saver didn't work, etc. - no deal breaker, but all works well in 16.10.)