PageLog syslog doesn't redirect entries to journal or /var/log/syslog

Asked by Ubay Dorta Guerra on 2017-03-17

Hi,

   I have a fresh installation of Ubuntu 16.04 and I have set up a CUPS server (CUPS 2.1.3). I have enabled PageLog and entries are recorded in /var/log/cups/page_log but if I change the directive PageLog to "syslog" in /etc/cups/cups-files.conf, the entries are not stored in journal nor /var/log/syslog.

   Do I have to change any other configuration file?

   Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Ubay Dorta Guerra
Solved:
2017-03-21
Last query:
2017-03-21
Last reply:
2017-03-18

Did you restart the CUPS service to reread the configuration?

Ubay Dorta Guerra (ubay) said : #2

Yes, and I restarted the server.

El 18/03/17 a las 11:18, actionparsnip escribi├│:
> Your question #570535 on cups in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/cups/+question/570535
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Did you restart the CUPS service to reread the configuration?
>

---------------------------------------------------------------------------------------------
ADVERTENCIA: Sobre la privacidad y cumplimiento de la Ley de Protecci├│n de Datos, acceda a http://www.iac.es/disclaimer.php
WARNING: For more information on privacy and fulfilment of the Law concerning the Protection of Data, consult http://www.iac.es/disclaimer.php?lang=en

Ubay Dorta Guerra (ubay) said : #3

I have installed another Ubuntu server, but the version is 16.10 and CUPS 2.2.0. It shows the same behavior.

Ubay Dorta Guerra (ubay) said : #4

Same behaviour for Ubuntu Server 17.04 (Zesty Zapus) and CUPS 2.2.2.

Ubay Dorta Guerra (ubay) said : #5

      Reading the manual https://www.cups.org/doc/man-cups-files.conf.html I set PageLog to stderr instead of syslog and finally it worked! Now the entries are sent to the journald. I realised that setting PageLog to syslog it created a file called "syslog" in the configuration directory.

      The solution has been checked on Ubuntu Server 16.04-CUPS 2.1.3 and Ubuntu Server 17.04-CUPS 2.2.2