Media type for Brother HL-2500BN

Asked by Tim Jackson on 2016-11-17

Trying to upgrade my system to Ubuntu 16.04LTS, my HL-2500BN laser printer connects and prints OK, but the properties menu does not include any entry for setting brMediaType, required for printing on envelopes etc. This worked OK on 12.04.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2016-11-20
Last query:
2016-11-20
Last reply:
2016-11-19

Did you upgrade to 14.04 in between or did you wipe off Precise and do a clean install of Xenial ?

Tim Jackson (tim-tim-jackson) said : #2

Clean install. I am running 12 and 16 on different disks. I had previously some time ago attempted to upgrade 12 to 14, but installation failed, I'm not sure why.

How did you install the driver (if at all)?

Thanks

Tim Jackson (tim-tim-jackson) said : #4

Apologies for typo in title line, this is HL-2250DN printer, not 2500.

Installation was by System Settings / Printing / Add printer
Discovered two network printer options: LPD and DNS-SD
LPD option did not connect
DNS-SD option worked, except as indicated.
Driver installation was by following default "(recommended)" lines of automatic installation process.

I note that /etc/cups/ppd now contains one file: "Brother-HL-2250DN.ppd"

Brother make drivers for their devices. Update the driver using that. May help

Tim Jackson (tim-tim-jackson) said : #6

Brother does not offer a .ppd file for this printer
They offer a cupswrapper/LPD driver which is what I had been using under 12.04
Attempting to install this using their installer on 16.04 installs but gives a "ubuntu internal error" and does not connect.

Are you sure of the model number?

Tim Jackson (tim-tim-jackson) said : #8

It is an HL-2250DN, as I corrected in an earlier message. I seem to have got my fingers in a twist when typing the title.

Then run:

wget http://www.brother.com/pub/bsc/linux/dlf/hl2250dnlpr-2.1.0-1.i386.deb

sudo dpkg -i hl2250dnlpr-2.1.0-1.i386.deb

Once that installs, run:

wget http://www.brother.com/pub/bsc/linux/dlf/cupswrapperHL2250DN-2.0.4-2.i386.deb

sudo dpkg -i cupswrapperHL2250DN-2.0.4-2.i386.deb

You can then remove the printer you have setup and reboot, then setup the printer as you expect.

Brother loves Linux and make drivers for a lot of their range

Tim Jackson (tim-tim-jackson) said : #12

Doing "sudo dpkg -i hl2250dnlpr-2.1.0-1.i386.deb" gives me an error: "depends on libc6 ( >=2.3.4-1)."

My machine is an AMD64, is this connected with the problem?

Then run:

sudo apt-get -f install

Tim Jackson (tim-tim-jackson) said : #14

That seems to have fixed it. Deleted previous efforts and reinstalled printer using DNS-SD path and it now gets the correct menus.