Setting up Printer for Copy in XSANE on Ubuntu

Asked by Frank on 2013-06-28

I posted this same question on the Ubuntu Forum on 14 June 2013 - but having received no responses as of 28 June 2013, I thought I would post it again here.

While I've been scanning successfully using XSane and Simple Scan, when I attempted to use XSane (version 0.998 on 64 bit Ubuntu 12.04 LTS) in Copy mode it told me no printer was defined. I opened the "copy" tab in "xsane setup" and clicked the "Add printer" button, but no dialog appeared.

Apparently, this does not bring up a list of OS printers, as I would have expected, but adds the "define an existing CUPS printer" with various entries on the dialog box (e.g. "Name," "Command," and so forth). Since it looks like Ubuntu is using CUPS as an intermediary for all printers, I tried using the names I got from the "Printers" dialog from the icon in the upper right corner of the desktop, but none of them seem to be recognized. Specifically I used "Officejet-Pro-K5400" which seems to work fine when printing from the Adobe reader, and I set the Command line to "lp -P Officejet-Pro-K5400" which, again, is what shows up in the Adobe Reader.

Is there a way to use my HP Inkjet printer (which works just fine with Ubuntu) to print out scans directly from XSane? I can, of course, save the scan as a pdf or something and then print it, but it seems like I must be missing something somewhere. If so, how would I go about doing this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Frank
Solved:
2013-06-30
Last query:
2013-06-30
Last reply:
2013-06-28

Try grabbing the latest HPLIP

Frank (foberle) said : #2

Not actually solved, but ...

For starters, I do have the latest HPLIP.

What I found elsewhere and confirmed with the man pages was that the -P option to name the printer doesn't work with lp (the corresponding option is -d with lp); the -P option to name the printer can only be used with lpr. I assume I just missed an "r" when initially typing the command.

The "lpr -P" option does send output from XSane to the printer, but it isn't useful because the image of the scan is always shifted upwards such that the top portion is cut off. I tried rescanning and selecting just a portion, but whatever was scanned was always offset towards the top of the page.

It's probably not worth continuing the effort to figure it out though, so I gave up. You get what you pay for, as they say, so I shouldn't complain.