How to solve libcups2 and libcupsys2 confilct?

Asked by Elyser Estrada on 2013-02-26

I'm in Ubuntu precise. I'm recompiling and old code that is needing libcupsys2. After downloading it and trying to install it get conflict with the actual package libcups2.

How can I resolve that??

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2013-02-27
Last query:
2013-02-27
Last reply:
2013-02-27
Manfred Hampl (m-hampl) said : #1

The package libcups2 should provide the functionality of libcupsys2. So there should not be the need for installing any libcupsys2 package.

Maybe you have to install libcups2-dev which delivers libcupsys2-dev functionality.

What error messages do you get when you try compiling without libcupsys2?

actually i'm installing first some libraries needed to begin the compiling process. I'm trying to install libfox-1.4, which needs libcupsys2. That's why i downloaded libcupsys2 and tried to install. The code to be compiled is old, that's why i'm trying to setup the old versions of the libraries.

Best Manfred Hampl (m-hampl) said : #3

There is no package for libfox1.4 in precise (I guess the last version was available in karmic), but libfox-1.6 (which is not depending on libcupsys2). Have you tried using that one?

As you have already seen you might run into problems when you try installing outdated packages from other sources or older releases on your current Ubuntu system.

ok, libfox-1.6 is there and it does not depend on libcupsys2. Thanks.

My intention was to use the old libraries trying to avoid errors at compilation time, due to possible variations on the new versions of the libraries.

thanks a lot

Thanks Manfred Hampl, that solved my question.