Canon i560: Images Don't Print The Correct Colour

Asked by Tony Brown on 2012-12-09

Hello - I have a printing problem and hope someone can offer me a solution. I have had Ubuntu 12.04 recently installed, and my printer is a Canon i560. Everything works ok and prints out ok, but any inserted images are not printed in the correct colour. They all print out in a dark brown/purple colour. The text fonts in Write all print out in colour correctly, background colour fill prints correctly, but If I insert an image into Write documents, or any other application, eg a bluelogo, it prints out in a brown/purple colour. The rest of the text prints correctly. It doesn't matter what the image/colour is, they are printed in the same brown/purple colour. All PDF's have the same problem, the whole PDF is printed in this brown/purple colour. It's not my printer - it prints out perfect colour reproduction from my other computer, which operates with Windows. I have checked all my printer settings and they seem to be all correctly set for ubuntu 12.04/Write etc. It just seems to be images can't be printed in the correct colour. Has anyone an idea why this is happening, and if there is a solution to this problem? Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Tony Brown
Solved:
2012-12-11
Last query:
2012-12-11
Last reply:
2012-12-10

How did you install the driver?

What is the output of:

lsb_release -a; uname -a; lsusb

Thanks

Tony Brown (tonybrown) said : #2

Hello - thanks for taking the time to respond. One thing I forgot to add in my original request for help, is that to get my Canon i560 printer to work, the person who installed Ubuntu 12.04 for me, had to add a workaround to get the printer to work. Perhaps this is why I have this problem, and perhaps I should contact them again to resolve this. In view of this, if I have wasted your time, please accept my apologies. However, here is the information you requested from my Terminal:

tony@Ubuntu-12:~$ lsb_release -a; uname -a; lsusb
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux Ubuntu-12 3.2.0-34-generic-pae #53-Ubuntu SMP Thu Nov 15 11:11:12 UTC 2012 i686 i686 i386 GNU/Linux
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bc2:3000 Seagate RSS LLC
Bus 003 Device 002: ID 045e:006a Microsoft Corp. Wireless Optical Mouse (IntelliPoint)
Bus 003 Device 003: ID 046d:08da Logitech, Inc. QuickCam Messanger
Bus 004 Device 002: ID 0aec:3260 Neodio Technologies Corp. 7-in-1 Card Reader
tony@Ubuntu-12:~$

Did you try installing the Canon driver from the deb files from the Canon Europe website?

Tony Brown (tonybrown) said : #4

Sorry - but I can't contact the person who installed ubuntu 12.04 for me, and also iinstaaled a work around for the printer installation. I will mark this asa problem solved until I can find out the exact procedure used to install the i560 printer. Thanks for your time and input.