I can't install printer drivers for my Canon Pixma MP550

Asked by assignedexpectsholKurt Jørgensen on 2012-11-07

My Canon Pixma MP 550 works fine in Windows. I can't get it to work with Ubuntu. I only seem to be able to find drivers that relate to Windows, so please help me to get my machine to work with Ubuntu

Kurt Jørgensen

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-11-10
Last query:
2012-11-10
Last reply:
2012-11-10

What windows does or doesn't do is of near zero value. It is a completely different OS with completely different support.

Did you check the Canon Europe website?

Tu. I'll do that now. Until now I've checked Canon.com.
Kurt

Thank you. I've found that page, and because I don't know whcih program to choose, i've downloaded all on that page (=1). I would like to test the programs and see my printer work, but I don't seem to be able to. when I click the downloaded files (programs) to install them, nothing happens.
Please help

mkdir ~/Canon
cd ~/Canon
wget https://dl.dropbox.com/u/8850924/MP550_debian_driver_pack.tar
sudo apt-get install unp
unp ./MP550_debian_driver_pack.tar
unp ./cnijfilter-mp550series-3.20-1-i386-deb.tar.gz
cd cnijfilter-mp550series-3.20-1-i386-deb/packages
sudo dpkg -i *.deb
sudo apt-get -f install
cd $HOME
rm -r ~/Canon

I'm sorry. I can't install "sudo apt-get install unp" or any other program. Perhaps it's because I haven't god the rights, or perhaps it's just because I don't understand how Linux/Ubuntu works.
Thank you everyone for trying to help me

Warren Hill (warren-hill) said : #7

open a terminal (CTRL+ALT+T) and enter the following command

-----------------------------------------
lsb_relase - a; uname -a; id
----------------------------------------

You should see something similar to this

~$ lsb_relase - a; uname -a; id
No command 'lsb_relase' found, did you mean:
 Command 'lsb_release' from package 'lsb-release' (main)
lsb_relase: command not found
Linux dell 3.2.0-32-generic-pae #51-Ubuntu SMP Wed Sep 26 21:54:23 UTC 2012 i686 i686 i386 GNU/Linux
uid=1000(warren) gid=1000(warren) groups=1000(warren),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),109(lpadmin),124(sambashare)
 ...

If this shows you are a member of the sudo group you have the privileges to run the command and just need to enter your login password and Andrews commands should work.

If you are not shown as being a member of the sudo group or are but do not know your password give us the output of the commands in this post and we will advise what you need to to to get the required privileges.

When you use sudo, you will not get a feedback, just type your password and hit ENTER. Your first account is the effective admin account. You can run it in a terminal (Launch a terminal by pressing CTRL+ALT+T)

Thanks actionparsnip, that solved my question.