Problems with Epson xp-300 printer driver

Asked by lee vought on 2012-10-26

Hi. I have Ubuntu 12.04 and I recently bought an Epson small-in-one xp-300 printer. I know the epson website has the drivers and I downloaded them but I cannot make them work from there. I'm decent with Ubuntu but am having toruble with this. My version didn't come with synaptic for some reason but I installed through the marketplace and still cannot get it to work. The printer is supported but maybe I need simple instructions to install it. Is there a way I can do it through the terminal? I'm pretty frustrated and would appreciate any help. Thanks, Lee Vought.

Question information

English Edit question
Ubuntu cups Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Warren Hill (warren-hill) said : #1

The installation manual is here

and the drivers are here

because Ubuntu is Debian based you want the .deb driver choose i386 if you are running 32bit and amd64 if you are running 64bit.

In the manual follow Debian instructions. Any command shown with a # at the beginning needs to be run with root privileges so must be prefixed with sudo. For example where the manual says

# dpkg -i epson-inkjet-printer-<Printer name>-<Version>_<Architecture>.deb

The command is

sudo dpkg -i epson-inkjet-printer-<Printer name>-<Version>_<Architecture>.deb

Let us know if you have any difficulties

What is the output of:

uname -a


lee vought (leevought) said : #3

Thanks guys, That solved my problem. Do I do the same for the scanner? Can't get that one working. Separate driver? And I really do appreciate what you guys do. Everytime I come running with my tail between my legs you guys are here. You just rock!

All you have to do is hit the Epson website, it's all there. Its the same as you would do for Windows if you didn't have the driver CD. Did you check the site yourself?

For 64bit, you'll need:

For 32bit, you'll need

lee vought (leevought) said : #6

Thanks actionparsnip, that solved my question.