How to Install Print Drivers from Samsung?

Asked by Tom Steidel on 2012-10-22

I bought a Samsung SCX-3405 to replace my now-dead HP printer, unpacked it, downloaded the Unified Linux drivers from the Samsung website for this multifunction machine, and have them unpacked and on my desktop. I tried to simply double-click on the "autorun" file but received a response that I don't have root permission as a super-user to do this. I suspect I must enter something in the Terminal mode, using a "sudo" command, but as a newbie, I don't know how to format the command.

Hopefully, this is easily solved with someone's help out there. Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Tom Steidel
Solved:
2012-10-23
Last query:
2012-10-23
Last reply:
2012-10-23

What is the file you are running and where is it located? Once you give that, we can advise. All details are case sensitive so if some letters are capitalized, please give them as capitals.

Thanks

Tom Steidel (tsteidel) said : #2

The file sets downloaded from Samsung are located on the desktop, with duplicates in my file named "User" The file structures look like this:

cdroot [folder]
    Linux [folder]
         i386 [folder]
         noarch [folder]
         x86_64 [folder]
         check_installation.sh [file]
         check_packages.sh [file]
         install.sh [file]
         Installer.htm [file]
         OEM.ini [file]
         uninstall.sh [file]
    autorun [file]

cdroot (2) [folder]
    Linux [folder]
         addressbook [folder]
         emailbook [folder]
         phonebook [folder]
         psu [folder]
         wirelesssetup [folder]

cdroot (3) [folder]
    Linux [folder]
         smartpanel [folder]
    MANUAL [folder]
         Samsung SCX-3400 Series [folder]

I have already downloaded the MANUAL separately from Samsung, and don't necessarily need the smartpanel, so we can probably forget cdroot (3).

I don't ever intend to use the wirelesssetup (allows iPhone and iPad users to print wirelessly from their devices), so we can also forget cdroot (2).

I have a dual-boot machine that is partitioned to run either Windows XP SP3 or Ubuntu 10.4 LTS, but I seldom, if ever, run Windows, except at tax time when I use Turbo Tax.

I think the focus is on cdroot/autorun which, I think, will do the rest of the job.

I hope I've answered your questions, I deeply appreciate your help, and look forward to your reply, as well as help from anyone else who can chime in.

Thanks!

so are you running the 'install.sh' file?

Warren Hill (warren-hill) said : #4

Try opening a terminal (CTRL+ALT+T) move to the directory with "install.sh" in it

cd <path to install.sh>

replace <path to install.sh> with correct path

then enter sudo ./install.sh

Enter password when requested, there is no feedback to tell you that its going in, just type your password and press enter.

Follow the on screen instructions.

If you have any more problems post the full output back here

Alfred (richet) said : #5

Hello, I have the same probleme as Tom, but I am more ignorant.
Please, how does a <path to install.sh> looks like?

Tom Steidel (tsteidel) said : #6

Hi Alfred,

I'd say we're both Linux-challenged, and equally unable to accomplish this task without specifics.

Warren,

Okay, to be sure I understand, since I'm not all that familiar with terminal mode commands, especially sudo, you want me to:

1. Open a terminal
2. Type "cd [add the path to the install.sh file]
3. Wait for an acknowledgement
4. Type "sudo ./install.sh"
5. Enter my password when requested to do so
6. Follow the screen instructions, hoping for the best
7. Let you know if this doesn't work, and post the full screen output in my message.

Should I do a command like "dir" to see where the system has placed the "install.sh" file first?
How do I specify the path to the "install.sh" file? Can you provide an example?

I'm sorry I have to ask you to walk me through this. I honestly want to learn, but have found very little information out there to help me understand how to help myself.

Thanks, again, and it looks like Alfred will also benefit from your response, as well.

Tom Steidel (tsteidel) said : #7

Hi again, Warren,

Would the correct path be something like "user/cdroot/Linux" where I am signed in as "user"?

Tom Steidel (tsteidel) said : #8

Warren,

I just went into terminal mode and asked for a directory:

user@user-desktop:~$ dir
autorun dwhelper RealPlayer11GOLD.2.bin
cdroot examples.desktop Smartpanel_1.01.tar.gz
cdroot\ (2) mediaplayer-5.2-viral Templates
cdroot\ (3) Music UnifiedLinuxDriver_1.01.tar.gz
Desktop Pictures Videos
Documents PSU_1.01.tar.gz
Downloads Public
user@user-desktop:~$

The "install.sh" file is within a folder named "Linux" which, in turn, is in the folder "cdroot" identified in the directory listing above.

sudo ~/cdroot/install.sh

Should do it

Tom Steidel (tsteidel) said : #10

Hi Andrew,

I tried your solution, but it failed:

user@user-desktop:~$ sudo ~/cdroot/install.sh
[sudo] password for user:
sudo: /home/user/cdroot/install.sh: command not found
user@user-desktop:~$

Tom Steidel (tsteidel) said : #11

Andrew, Warren, and Alfred,

I took a cue from Andrew's suggestion and, instead, entered:

sudo ~/cdroot/Linux/install.sh

Where the "~" is my home directory, "cdroot" is the top-level folder downloaded and unpacked from Samsung, "Linux" is the folder within "cdroot" that contains the "install.sh" file, and lastly "install.sh" is the installation program. See the results of my terminal mode command "dir" that listed all folders for me in this string, above.

It worked perfectly; no hitches. I'm fully installed, and working A-Okay.

Thanks, Andrew and Warren, for your help. You challenged me to dig a little deeper, and I learned from the experience.

Alfred, it's not all that hard. I even feel emboldened enough to offer to give you a hand if you need one.

A grateful Ubuntu user,

Tom

Alfred (richet) said : #12

Thanks a lot.
I did nothing special and now it works. :-)