Printing PDF or PS file fails with Acrobat or Okular

Asked by Waldgeist_dI on 2012-10-12

Hello,

first I'd like to acknowledge that there are quite a few bugs/questions pertaining to my problem already filed. However, none of them exactly match the symptoms I see.

My OS: Kubuntu 12.04 LTS 64 bit with latest updates

I am trying to print a variety of PDF or PS files on a Canon Pixma iP4850 using the latest TurboPrint driver. The TurboPrint monitor will show a pending printing task but that vanishes after a few second without an actual print (or Preview in my case). This happens both with Okular and Adobe Reader. However, ePDFViewer will print just fine (Poppler vs. GS?). Other file types are also printed without problem.

Printing a document with

lp -d iP4850-TurboPrint Document.pdf

or

lp Document.pdf

will generate an output such as

request id is iP4850-TurboPrint-90 (1 file(s)).

If I am quick and lpq I see:

iP4850-TurboPrint is ready and printing
Rank Owner Job File(s) Total Size
active (null) 90 untitled 201728 bytes

The task also appears on the TurboPrint monitor, but nothing happens afterwards, eventually the queue will be empty again.

If I force PDF output as image/raster in Acrobat or Okular the number of pages will quadruple compared to the document pages (presumably the four colours?) and printing will commence.

cups-filters are installed; switching to

lpadmin -p iP4850-TurboPrint -o pdftops-renderer-default=pdftops

doesn't help.

What can I do to shed further light?

Best regards

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-12
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask Waldgeist_dI for more information if necessary.

To post a message you must log in.