Epson TM-T20 problems CUPS 1.5.3 Ubuntu 12.04x64

Asked by Criatura on 2012-09-29

Hi, I'm using a TM-T20 thermal printer. In Ubuntu 12.04x64 with CUPS 1.5.3 The printer is serial and I'm using a serial to USB cable in order to use it in a laptop.

Driver readme:

---------------------------------------------------------------------
3. Operational environment
---------------------------------------------------------------------

This software supports the following environments.
Operations in an unsupported environment are not guaranteed.

* Operating System
  - openSUSE 11.1
  - Ubuntu 9.04

* Hardware:
  - Intel x86(32bit) architecture.
  - Intel x86_64(64bit) architecture.

* Related software
  - CUPS Ver.1.1.23 or later
      <http://www.cups.org/>

I connected the cable and check the CUPS web interface in order to install the printer, it doesn't work.

Then I added it with this command :

sudo lpadmin -p tm-t20 -E -v serial:/dev/ttyUSB0 -P /usr/share/ppd/epson-tm-t20-rastertotmt.ppd

But before I made chmod 777 /dev/ttyUSB0 (I have to this each time I want to use the printer).

Then the printer appeared at the web interface and I just added following the instructions (selecting the correct driver and giving the PPD).

Then the printer started to working, but wasting paper (no matter what I send to it, it prints 30 cm of paper always), then I use options:

lp -d tm-t20 -o media=Custom.200x258 -o source=DocFeedCut document.ps

Then I tried with different options of paper size, until I find the best:

lp -d tm-t20 -o media=Custom.210x220 -o source=DocFeedCut document.ps

But another day. I tried to print and the printer was simply not cutting the page, then sometimes it print or sometimes not (always whitout cutting the paper) and CUPS web interface tells me that the Job has been finished. Sometimes prints garbage. Then I change the cable serial to USB, but nothing happens.

Sometimes I get this error:

tm-t20-212 Unknown Withheld 2k 1 stopped
"/usr/lib/cups/filter/pstopdf failed"

If I try with just plain Text:

The first time I turn it On prints, then stops printing and in the web Interface I see job completed.

In the logs appears this:

W [28/Sep/2012:14:35:43 -0300] failed to CreateDevice: org.freedesktop. ColorManager.AlreadyExists:device id 'cups-tm-t20' already exists

I tried changing almost every option of the printer.

EDIT:

After installing / reinstalling CUPS (1.5.3) and epson driver, the printer now just prints garbage.

someone using this printer in Ubuntu? what should I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Criatura
Solved:
2012-10-01
Last query:
2012-10-01
Last reply:
2012-09-29

Natty is EOL in less than a month. Why not clean install a new install of Precise. Not only is it the latest stable version of Ubuntu, it is also LTS so supported until 2017.

Criatura (notosil) said : #2

I'm ussing not using Natty. I'm using Precise.

Then why did you add:

  - Ubuntu 9.04 environment
     - libusb-1.0-0-2:1.0.0-1
     - cups-1.3.9-17ubuntu3.4

To the initial question?

Criatura (notosil) said : #4

because the readme of the epson driver says that the driver has been tested just with that version of Ubuntu. I added just an aditional information. I will edit my question to make things clear, sorry.

Criatura (notosil) said : #5

Finally after a lot of pain. I discover that the problem was the serial to USB cable (in order to connect the serial printer to an USB port). I tried with two different serial to USB cables, but the problem persists and finally I conclude that The printer works erratically if is not connect to a "real" serial port. I tested the printer under identical conditions in a PC with a serial port and it works perfect, just installing the driver provided by epson and giving chmod 777 to /dev/ttyS0. At the job list sometimes I see the error: "/usr/lib/cups/filter/pstopdf failed". But the printer prints ok, like no error occurred.