Printer Canon IP4850 doesn't print the whole text

Asked by Cedara on 2012-08-06

Version: Ubuntu 12.04 - 32bit - on an AMD64
Printer: Canon IP4850
Printing with: CUPS+Gutenprint v.5.2.8-pre1

I only noticed today that the printer doesn't print the whole text.

For a full page, there's about 3cm of the bottom of the page missing (ca. 6 lines). If it's just a small text which doesn't reach the bottom, the last line is missing. Also, the last one or two lines before the missing text doesn't seem to use enough ink, it's greyer than the rest of the text.

I've double checked with a Windows PC - the problem isn't when using Windows and a Windows driver, so it's definitely a driver issue and not a printer one.

Should I file a bug report?

Tia,
Cedara

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-08-07
Last query:
2012-08-07
Last reply:
2012-08-06

How did you install the driver?

Cedara (cedara2) said : #2

Answer to #1:

I installed it when I set up the system, with the system menu thing (not English native, so I have no idea how you call that). I went with what was recommended from the system.

Did you go to the canon site to grab the driver?

Cedara (cedara2) said : #4

Answer to #3:

No, I used the one ubuntu suggested. The canon site suggests it for 10.04 only so far.

Run:

mkdir ~/canon
cd ~/canon
wget http://files.canon-europe.com/files/soft40246/Software/ip4800_redhat_debian_guide.tar
sudo apt-get install unp
unp ./ip4800_redhat_debian_guide.tar
rm ./ip4800_redhat_debian_guide.tar
unp ./cnijfilter-ip4800series-3.40-1-deb.tar.gz
cd ./cnijfilter-ip4800series-3.40-1-deb/packages

Now run:
uname -a

if you see:
i686

run:
sudo dpkg -i ./cnijfilter-common_3.40-1_i386.deb ./cnijfilter-ip4800series_3.40-1_i386.deb

otherwise run:
sudo dpkg -i ./cnijfilter-common_3.40-1_amd64.deb ./cnijfilter-ip4800series_3.40-1_amd64.deb

Remove the printer you added and reboot, then resetup the printer

Cedara (cedara2) said : #6

Answer to #5:

At first it didn't seem to solve it. However, when I didn't choose the 4800 series but the USB printer with a different item URI (cnijusb) that worked. So, thanks!

Cedara (cedara2) said : #7

Thanks actionparsnip, that solved my question.

Cedara (cedara2) said : #8

Belated addition:

While it now prints in full, the downside is that I can only print in 600 dpi, not 300 dpi anymore. So, no saving on ink possible anymore. (I can live with that for printing in full.)