HP Officejet 6600 printer only supported by hplip 3.12.4 or newer in Ubuntu

Asked by Tim Rogers on 2012-08-04

I can not get HP Officejet 6600 software installed. Ubuntu does not have a default setting for this printer on their list and will not allow the software to install it appears.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-04
Last reply:
2012-08-04

Please tell do you have already intalled and used hplip package to setup your hp printer ?

Tim Rogers (tarog52) said : #2

What is hplip package? I used CD that came with printer.

Do not use software made for Windows in Ubuntu... so so you have simple tried to add your printer

https://help.ubuntu.com/11.04/ubuntu-help/printing-setup.html

then if doesn't works install and use the hplip software simply install it from software center

i guess you are new to Linux/Ubuntu so please read http://ubuntu-manual.org/

Please first read this:

http://hplipopensource.com/hplip-web/models/officejet/officejet_6600.html

It shows your printer requires hplip version 3.12.4 or higher.

However, the default hplip package in Ubuntu 12.04 only installs an older version, version 3.12.2, which does not support your printer.

So you should download and install hplip version 3.12.6 here:

http://hplipopensource.com/hplip-web/gethplip.html

Follow these installation instructions, which are more detailed:

http://hplipopensource.com/hplip-web/install/install/index.html

You can go to the hplip site and install the .run file, mark it as executable then run it as user (without sudo) in terminal and itwill install.

cd $HOME
wget http://prdownloads.sourceforge.net/hplip/hplip-3.12.6.run
chmod +x ./hplip-3.12.6.run
./hplip-3.12.6.run

It will install

Can you help with this problem?

Provide an answer of your own, or ask Tim Rogers for more information if necessary.

To post a message you must log in.