printer problems since last update

Asked by Don on 2012-06-24

I have a Epson stylus rx 500 and since my last update I cant see the text when I try printing a page from my bank of my statement , only highlighted items.

 I discussed the problem with Epson and it seems to be a software issue .?

I tried to upload the print to a file and print from there and had the same results.

I also tried different web sites with the same results.

I did test pages and they are o.k.

Could this be a software issue or is it more likely my printer ?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-30
Last reply:
2012-06-30

This question was reopened

michael (yellupcm-gmail) said : #1

Is the printer a Epson Stylus PHOTO RX 500? I think I would reload Linux drivers first.
http://driverscollection.com/?H=Stylus%20Photo%20RX500&By=Epson&SS=Linux
http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do
http://avasys.jp/eng/linux_driver/download/lsb/epson-inkjet/escpr/
The last two sites are will probably be the best. It has been some time since I started using the Epson Stylus Photo RX 500. Can't remember which driver I downloaded, but it from Avasys site. Coluld not fine driver for 500, probably used the one that had a number close to 500.
HTHs

Have you tried removing the printer, rebooting then readding it?

Don (climber-metrocast) said : #4

Tried rebooting the printer and no change .
I'll try one of your other suggestions and see what happens.
I'll let you know what happens .
Thanks in advance and for your help so far !!!

Don (climber-metrocast) said : #5

I tried the - http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do
and the - http://avasys.jp/eng/linux_driver/download/lsb/epson-inkjet/escpr/
But I'm a caveman and got lost .
I don't know where to go or what to do at these sites .
Sorry , I'm a mechanic .
Can you help me ?

michael (yellupcm-gmail) said : #6

Will try to help you navigate the sites. Late tonight, will do tomorrow.

michael (yellupcm-gmail) said : #7

Try this site.

http://download.ebz.epson.net/dsc/search/01/search/searchModule

When it asks for printer name, put RX500 in. If you put in complete name, it will not give anything.
Use the download that has the word CUPS in it.
Also download Scanner Driver.

michael (yellupcm-gmail) said : #8

Below the place you enter RX500, be sure to put Linux in OS box.

Did you try removing the printer then reboot the system, then re-add. I never said to reboot the printer....

Don (climber-metrocast) said : #10

Tried - http://download.ebz.epson.net/dsc/search/01/search/searchModule
No match. Tried Epson Stylus Photo RX 500 , and parts of that with no results .

** actionparsnip (andrew-woodhead666) said 3 hours ago: #9

Did you try removing the printer then reboot the system, then re-add. I never said to reboot the printer....

Yes , I unplugged the printer from the 'puter and from the electricity ,then removed the old driver program from the 'puter , then installed the driver then plugged it back in and rebooted the printer with no results .

If you meant for me to reboot the 'puter , no I didn't do that but will try that in the order of - unplug printer / remove printer driver / reboot 'puter / install driver / plug printer back in / reboot driver ; in that order.

I'll let you know .

Don (climber-metrocast) said : #11

tried that route with no success again .
Also tried plugging printer in before and after 'puter reboot.
Tried leaving disk in then rebooting 'puter and putting disk in after 'puter reboot.

Still getting all printable areas but no text .

I hope there is something I'm not seeing !

michael (yellupcm-gmail) said : #12

http://download.ebz.epson.net/dsc/search/01/search/searchModule

When it asks for printer name, put RX500 in. If you put in complete name, it will not give anything.
Use the download that has the word CUPS in it.
This has worked three times today.
Must have RX500 in the top box and Linux in bottom box. Very important.

When Actionparsnip said to remove printer, did you go to Printing window, and delete Stylus-Photo-RX500?
Don't forget to install scanning driver.
Also which Ubuntu release are you using?

Don (climber-metrocast) said : #13

file:///home/don/Desktop/Screenshot.png
Hopefully you can access this !
This is a screen shot saying there is nothing for rx 500 !
What next ?

The only way that is visible is on your system, use something like imageshack etc to host the image so it makes a URL out of the image

Don (climber-metrocast) said : #15

Like I said , I'm a mechanic And your statement is way out of my league !
Teach me !
How do I do this ?

go to http://www.imageshack.us/
Upload the image there, then post the URL of the image which is generated

Don (climber-metrocast) said : #17

Thanks , I'll try that and get back to you .
Have a nice 4th of July !

Here in the UK, 4th July doesn't mean much at all, just another day

Don (climber-metrocast) said : #20

Downloaded the cups one and still nothing.
I think it's my printer !?
Thanks for your help !!!

Can you help with this problem?

Provide an answer of your own, or ask Don for more information if necessary.

To post a message you must log in.