usblp0 removed after every print job

Asked by Mitch Claborn on 2012-05-17

Ubuntu 12.04 64 bit (also 32 bit is affected)
Zebra LP 2844-Z USB printer - connected with a generic "raw queue" driver.

usblp0 appears to disconnect after every print job and then automatically reconnect after 8 seconds. The next job to the printer won't print until it is reconnected. This is a problem for us in a high volume printing scenario.

Here are messages from syslog:
May 17 16:47:17 mlcx500 kernel: [25464.991868] usblp0: removed
May 17 16:47:25 mlcx500 kernel: [25473.131745] usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x0A5F pid 0x0027
May 17 16:47:25 mlcx500 udev-configure-printer: add /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/usb/lp0
May 17 16:47:25 mlcx500 udev-configure-printer: device devpath is /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
May 17 16:47:25 mlcx500 udev-configure-printer: Device already handled

Note the 8 second pause between the first and second messages.

Not sure where the disconnect is coming from.

It doesn't appear to be hardware related as I have the problem with various combinations of printer and computer.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-17
Last reply:
2012-05-17

I suggest you report a bug

Can you help with this problem?

Provide an answer of your own, or ask Mitch Claborn for more information if necessary.

To post a message you must log in.