Cannot print from Dapper

Asked by mokelvey on 2006-09-09

I cannot print.
The PPD for my printer is in the etc/cups/ppd/ directory. I downloaded it from the Ricoh site (where I also get my Mac and PC drivers for the same printer. It reads:

*PPD-Adobe: "4.3"
*%
*% Printer Description file
*% for "Ricoh Aficio 1224C PS"
*%
*% CreationDate: 2001/08/08
*% Modified: 2005/08/29
*%
*% COPYRIGHT (C) 2001-2005 RICOH COMPANY, LTD.
*%

and so on for several pages.

The print dialog box reads: "Name: Unknown" - then info about the job - then "State: Pending: printer-stopped." The print dialog box header reads: Aficio-1224C-PS - Paused.

Everything I try to print winds up like this. I could send a screen shot if that would help, but I have no idea how to get a print job completed.

It is taking me a long long time to get things working because I know very little about what I am doing, although learning more each day, but this is a slow train.

I would appreciate any help. Please.

mokelvey

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2006-09-17
Last reply:
2006-09-17
mokelvey (moky) said : #1

6 days gone by and no one seems to know why, and I cannot discover why. where is al this support?

mokelvey (moky) said : #2

Evrything is so cool about ubuntu Dapper - it looks cool, it sounds cool when it starts up, but many important things don't work. I can't print, as previously described. I can't connect to other computers on my LAN, not connect to my ubuntu computer (17" Powerbook PPC) from other units on the LAN.
I can get and send mail, I can work the internet.

I can send endless requests for help, but that doesn't seem to work, either. I search through the support files, help files, forums, and cannot find anything that makes sense about how to sole these relatively simple problems.

I nothice that anwar, Dean Sas, Dmitri Alenitchev, Kirjanov D.A., bigjoe, aK and scinbc are subscribers to this ticket (#1741), but they are silent. I have not found the answer to these "simple" problems in the in the tutorials, either. It's all so cool, so hip, so knee-deep in geekspeak, and so devoid of understanding that I wonder what all the fuss is about.

mokelvey (moky) said : #3

The link below has a GREAT explanation of why I am having a hard time printing from Open Source ubuntu CUPS:
http://www.catb.org/~esr/writings/cups-horror.html I discovered this link just a few minutes ago, and it inspired me to write the following.

Finally, after punching buttons all around on the "Printers" GUI dialog box I accidentally foound something called "Detect LAN Printers" and turned it on. By default, this little beauty is turned OFF abd there is not one clue anywhere that it should be turned on. IMHO this is typical Open Source snobbery, or just plain carelessness.

When I turned that on, printers appeared, including Page Sender, a Canon Bubblejet connected to my wife's G4, Adobe PDF7 and two versions of the Ricoh 1224 (connected to 2 different Macs on the LAN). But I could not configure the Ricoh 1224. I can't get permission. There's nowhere to sign in at the CUPS site (http://localhost:631/printers/ - which I also discovered by accident) for these printers. For some reason I can configure PagesSender and PDF7, but I am not allowed anywhere else to configure the page size tray or anything else.

CUPS help is no help. Provided scripts in CUPS help produce no results in terminal, probably because I don't know a lot about how that works.

It's really Open Stupid, because a seemingly friendly printer GUI is provided, but nothing works in a user friendly way. This is the Achilles heel of Open Source GUI design - the people who design these cute things, don't understand that the user may not know how to dig out the clues to Open the Mystery.

This support request is STILL not answered, but I continue to dig away at it and maybe, a month from now or so, I will be able to accomplish what should take me about one minute on a Mac and maybe 30 minutes if I'm lucky on a PC running Windoze.

Open Source is open only to those who can understand and manipulate the arcane UNIX language. I can appreciate the effort that has gone into the ubuntu project, but it is a long, long way from Mandella's description of what the word means, and ubuntu developers have to be more thoughtful about the end user if they want their project to succeed.
mokelvey

Dean Sas (dsas) said : #4

Mokelvey, we are all volunteers, helping out in our spare time, a simple reminder saying "has anyone got any ideas on this" would have been much better than ranting, and name-calling. Don't forget that this whole operating system is gave away free and a great deal of development is done by volunteers. Don't forget that you are asking people you are asking to give up their free time to do you a favour, the least you can do is to be polite, no matter how frustrated you may be.

"discover network printers" is turned off because it's a potential security hole. The cups-admin webpage is disabled for the same reason. (see https://launchpad.net/distros/ubuntu/+source/cupsys/+bug/8975).

There's some discussion on how to enable the web interface here: http://ubuntu.wordpress.com/2005/10/13/enabling-cupsys-web-admin-interface/
If there's anything you can't understand or follow then please reply to this ticket saying so.

Personally I don't really use printers so I may not be able to help, perhaps if you gave more details of your problem someone else will.

Are all the printers you are trying to print to,network printers? Do any of them work?

mokelvey (moky) said : #5

Dean!
Thanks for your comments and response. Your response only proves what I have been writing: anything less than explicit instruction in a given unfamiloiar situation is useless, no matter how much time you volunteer, or in my case, waste on a problem. For example: as mentioned previously, I am trying to get one network printer working - the Ricoh Aficio 1224 C - also, I mentioned that I got the PPD from the same source where I got the drivers for my Macs and PC, so one could readily deduce that I have that printer already functioning on the network. So why do you have to ask these questions? Could you not infer the answer from the "obvious". I am not trying to pull your chain - I am trying to make a point. As for doing me a favor, I am deciphering "your" operating system as a matter of curiosity - it is an endeavor to understand, and to contribute if I can. In some cases criticism can be a very positive contribution. Given the response to my queries, which with exception of yours has been virtually nil, I wonder that anyone who has not spent years learning UNIX can accomplish anything at all with ubuntu and similar systems. If your goal is to spread the gospel of free software to the people, well and good. But we need to be able to somehow get a handle on it.

I have another problem that seems impossible: when I open a terminal and try to access "etc/cups/cupsd.conf" I get a "permission denied". When I try to alter the file from the File Browser, I don't have permission to save the changes. I know there must be some way to log in and change these files, but I don't have a clue. there's nothing in the desktopguide that tells me how to get permission to change these files or how to log in. To you guys who are adept, I must be an idiot. I can't even log in to my own operating system and change a cupsd.conf file. When I open the terminal there is my user login followed by a :~$ I can man ??? and ls and cd and cd .. and whatis, and a few other things, but nowhere can I find a clue as to how to configure my printer using CUPS. How do I exec "login" from the lowest level "sh"? these and many other mysteries await me.
mokelvey

Dean Sas (dsas) said : #6

I meant "could you print from linux to any of the other printers" rather than "is your printer hardware knackered", I apologise for not being more clear. Also linuxprinting.org is probably the best source for printing information in linux, your printer is here: http://www.linuxprinting.org/show_printer.cgi?recnum=Ricoh-Aficio_1224C

Yes, constructive criticism can be useful, however comments like "Open Stupid" and anecdotes like "Open Source is open only to those who can understand and manipulate the arcane UNIX language" is not constructive criticism. If you'd care to trade anecdotes, my computer illiterate mother has no problems using Ubuntu. If you have specific constructive criticism to make the place to do it is http://bugs.ubuntu.com/

To edit /etc/cups/cupsd.conf you need to prepend the command with a "sudo" (switch user, do ....) command. "gksudo gedit /etc/cups/cupsd.conf" will open the file with the necessary privileges in the Text Editor accessible from your menu. I think that there's something inside the "Linux Basics" chapter of the Desktop Guide about getting root access (sudo -i), which is the way to act as a different user, instead of trying to rerun "login".

I don't think you're an idiot, there is a problem that if things don't "just work" in computing then it can be tricky to fix our solution to that is to concentrate on making things "just work" as much as we can.

mokelvey (moky) said : #7

Dean!
Again - I appreciate your response, especially in view of my seemingly off-hand rants quoted above. "Open Stupid" is maybe a little strong, but not that far off if you stipulate that a GUI is stupidly designed if its use is not readilly deducible.
At the prompt in Terminal - usr: ~$ - I entered "gksudo gedit /etc/cups/cupsd.conf" - I then hit "Enter" and the desktop went dramatically dark with a password dialog box highlighted. I entered my password, hit "Enter" and got another another prompt - usr: ~$ - no document to edit pops up or appears in the Terminal. i fitfully tried it a few more times, tried a few things that got me a "no such file" or "permission denied".
But none of this matters, because what I really need to be able to do is add and edit printers on the CUPS printer administration web interface, and THAT is also a conundrum. I won't bug you anymore - I know you must be getting tired of my complaints. The fact remains that ordinary activities in ubuntu, and UNIX in general, are beyond my grasp, and I bet your mother had some help.
In the 1980s, I had a Commodore 64, a primitive computer that I had to manipulate with code - I guess it was a primitive C+ or something. I could write text, make graphics bounce all over my TV screen, make electonic music and save things to a cassette recorder - all by writing code. But it was so primitive that it made sense.
Windoze and Mac are, after my experience with ubuntu (which is not over yet), are well worth paying for because I have to spend most of my time actually doing work on the computer, not fiddling around for weeks trying to get the damned thing to print or network (both necessaries are still beyond me). I pity the folks who must depend on free software, all the hours spent trying to learn how to perform a simple task, and in my case failing. I'm going to turn it off for a while.
Thanks again for your help.
mokelvey

Can you help with this problem?

Provide an answer of your own, or ask mokelvey for more information if necessary.

To post a message you must log in.