Brother HL-2270DW: network printer installation

Asked by William Pabon

Recently bought and connected on my network, Brother HL-2270DW printer using static IP address. No problem installing drivers and being recognized on Windows. I got from Brother a Debi package for the printer (cupswrapperHL2270DW) which I installed, apparently without problems (I can send an image if required). The problem is that, when I try to add the printer (System > Administration > Printing) and I choose to add a network printer, the system finds the printer with the correct IP address, but then it starts looking up for a driver and doesn't select the driver (cupwrapper) that I just installed. The system suggests alternatives but not the one that I installed. Any ideas on how to make the system select the correct one? Thanks for the help.

Question information

English Edit question
Ubuntu cups Edit question
No assignee Edit question
Solved by:
William Pabon
Last query:
Last reply:
Revision history for this message
William Pabon (williepabon) said :

The network connectivity is not the problem. Right now I can print with the printer using a driver available on the driver lists that is shown when the printing system is searching for a driver. No problem printing using a Brother DCP-1200 _CUPS-Gutenprint....but, with it I don't have all the printing features that the printer has. As I said on the original request I installed the cupswrapper and LPR drivers as instructed at Brother's website. Then I used the cups web interface to configure the printer without success unless I use any of the drivers listed. Please, help.

Revision history for this message
William Pabon (williepabon) said :

Let me restate my question in a different way. I have my HL-2270DW printed connected to my network. Per Brother instructions, I installed cupswrapperhl2270dw and hl2270dwlpr. Both show on the Synaptic Package Manager. Now, when I try to add the printer using the printing system (System -> Administration -> Printing), the printer doesn't show on the list of printers that have drivers. What else, should I do?

Revision history for this message
William Pabon (williepabon) said :

This problem is solved.
The installation of the cupswrapper package and/or the hl2270dwlpr does not indicate that it creates a ppd file. When I found (just by chance) the location of the ppd file (/usr/share/cups/model/hl2270dw.ppd), I just went through the procedure of adding the printer:

System -> Administration ->Printing, Add printer. Select network printer (and it was discovered). Select for connection: LPD network via DNS-SD. Click Forward and wait (the system will start to search for a driver) until I get to the screen of the print driver database. There I select the button: Provide ppd file. In the selection box I browse for the mentioned directory, and apply. That's it!