How do I install the Brother supplied driver for DCP-7040 printer in 64 bits Natty

Asked by Bill Risch on 2011-05-17

Binary package hint: cups

Description: Ubuntu 11.04
Release: 11.04
http://islandlinux.org/es/howto/upgrading-ubuntu-breaks-printer-cupsys
http://ubuntuforums.org/showthread.php?s=19034a55ba564183d92ac0602faa436e&t=1760613
I will add more info when I get on my other computetr

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: cups 1.4.6-5ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CupsErrorLog:

Date: Tue May 17 07:37:05 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101213)
Lpstat: device for Brother-HL-2070N-series: usb://Brother/HL-2070N%20series
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 046d:081b Logitech, Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
Papersize: letter
PpdFiles: Brother-HL-2070N-series: Brother HL-2060 Foomatic/hpijs-pcl5e (recommended)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_CA.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-9-generic root=UUID=dd4456b3-8670-47b7-9841-703d353578d6 ro splash vga=799
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/07/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1003
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M2N68-AM Plus
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1003:bd12/07/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N68-AMPlus:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Marius B. Kotsbak (mariusko) said : #1

The real bug is the missing driver support in Ubuntu, bug #425172. This reporter wants to install the drivers that Brother supplies at their website directly.

Marius B. Kotsbak (mariusko) said : #2

See comment: https://bugs.launchpad.net/ubuntu/+source/brother-lpr-drivers-laser/+bug/444147/comments/5

It seems that the 64-bits Brother drivers supplied with Ubuntu are has the 32-bits part mixed in somehow. Maybe Saïvann Carignan can help with this.

Marius B. Kotsbak (mariusko) said : #3

This error:

brother-cups-wrapper-laser1 conflicts with cupswrapperdcp1000
  cupswrapperdcp1000:i386 (version 1.0.2-1) is to be installed.

can be avoided by removing the Ubuntu package first:

"sudo aptitude remove brother-cups-wrapper-laser1"

Are you able to test this using a 32-bits Natty live CD.

Best Marius B. Kotsbak (mariusko) said : #5

graphius says here: http://ubuntuforums.org/archive/index.php/t-1124867.html that the drive for Brother DCP-7020 can be used with this printer. This is available by installing the package "brother-cups-wrapper-laser".

Bill Risch (brisch) said : #6

First: thanks everyone for the quick replies and the factual info to
solve the problem.
This info came at the right time as I was beginning to wonder if
there was a solution.
Went looking for this question this morning and it was already gone.
Had me going around in a circle for a while.
When I checked my e-mail all was made clear.

Second:
Rant or Humble Opinion take your choice.
I have been following the development forums for at least 4 years for Ubuntu.
my favorite command is ubuntu-bug and I use it a lot.
Now while I frequent launchpad quite a bit the question and answer
area was not on my list.
I suggest a sticky on the forums for a reference to the question and
answer area.
It saves a lot of time and seems to have the most competent
individuals around to answer questions.
If I had taken the time to find it I might have had my problem solved
a lot sooner.
Just one in the forum rut.
Comments welcome

>Your question #157939 on cups in Ubuntu changed:
>https://answers.launchpad.net/ubuntu/+source/cups/+question/157939
>
>Marius Kotsbak proposed the following answer:
>graphius says here:
>http://ubuntuforums.org/archive/index.php/t-1124867.html that the drive
>for Brother DCP-7020 can be used with this printer. This is available by
>installing the package "brother-cups-wrapper-laser".
>
>--
>If this answers your question, please go to the following page to let us
>know that it is solved:
>https://answers.launchpad.net/ubuntu/+source/cups/+question/157939/+confirm?answer_id=4
>
>If you still need help, you can reply to this email or go to the
>following page to enter your feedback:
>https://answers.launchpad.net/ubuntu/+source/cups/+question/157939
>
>You received this question notification because you asked the question.

Bill Risch (brisch) said : #7

Thank you that worked. I had downloaded drivers from the brother site but I always tried later drivers and not
falling back to previous versions.

Marius B. Kotsbak (mariusko) said : #8

Great that you finally got this solved :) And bad of Brother that they keep some part of the driver closed source and only 32 bits version.