Ubuntu

Need drivers of Canon iR2018N, iR2320L for Ubuntu 10.04 64Bit

Asked by ramsri on 2010-09-10

Anyone please help me out to find drivers of Canon iR2018N, iR2320L for Ubuntu 10.04 64Bit. I googled every where unable to find them. even I tried with Ubuntu 10.04 32Bit but no good just it is showing as print is sent and even job is completed but unable to get the print out. Please help me out from this issue.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-13
Last reply:
2010-09-30
ramsri (ramsri46) said : #2

Dear actionparsnip,

unfortunately UFRII/UFRII LT Printer Driver for Linux v2.10 I don't see for ubuntu 64 Bit desktop version.
I noticed that it is available for [64-bit]
Trubolinux 10 Server x64 Edition
MIRACLE LINUX V3.0 (Asianux Inside) x64 Edition
MIRACLE LINUX V4.0 (Asianux Inside) x64 Edition
Red hat Enterprise Linux V.4 x64 Edition
Red Hat Enterprise Linux v.5 x64 Edition
Mandriva Linux Powerpack 2008
Mandriva Linux 2008 Spring PowerPack x64 Edition
SUSE Linux 10.0 (openSUSE) x64 Edition
SUSE Linux 10.1 (openSUSE) x64 Edition
SUSE Linux 10.2 (openSUSE)
SUSE Linux 10.3 (openSUSE)
SUSE Linux 11.0 (openSUSE) x64 Edition
SUSE Linux 11.1 (openSUSE) x64 Edition
Fedora Core 4 x64 Edition
Fedora Core 5 x64 Edition
Fedora Core 6 x64 Edition
Fedora 7 x64 Edition
Fedora 8 x64 Edition
Fedora 9 x64 Edition
Fedora 10 x64 Edition
Fedora 11 x64 Edition
Cent OS 5.3 x64 Edition

Please let me know if I convert RPM to deb and install does it work because I even tried converting RPM files to deb with alien and tried printing it didn't worked either. Or canon has provided the source file please guide me how to build deb files for 64 Bit platform.

Thanks for your prompt response.

You can but it is VERY unstable. This is why 32bit is advised over 64bit, 3rd party companys still support 32bit much more. You can use alien to change the RPM to a DEB but I would not advise it. It's your choice. I would reinstall 32bit to accommodate your printer manufacturers average support (at least there are SOME linux drivers)
http://embraceubuntu.com/2005/09/23/installing-using-an-rpm-file/

Using RPM is heavily disuaded but if you REALLY want to then go for it.

ramsri (ramsri46) said : #4

Dear actionparsnip,

Thanks for all of your suggestion. Unfortunately I guess these(UFRII/UFRII LT Printer Driver for Linux v2.10) drivers are not working even in 32bit Ubuntu 10.04 I need to check it out with the Ubuntu 9.04 and come back again. In Ubuntu 10.04 when I give a print it is showing sent and even in the printer logs I'm able to notice the job is done but I don't see any printout. In out network we started migrating all our Windows OS to Ubuntu 64bit I tested almost all the applications alternative and forgot about this printer because I was in a thought that I can get them. Any I will keep on searching or I will try to build from the source which I found in the drivers package.

Thanks a lot once again.

ramsri (ramsri46) said : #5

Dear Actionparsnip,

Finally I tested today by converting RPM 64Bit driver to deb and installed so far from all the systems I'm able to give test prints. I will update in week days time.

Thanks for your help.

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Aurelien Jacobs (aurel) said : #7

I've Just got a Canon iRC2880 working on ubuntu 10.10 64 bits.

Here is what I did.

I got the UFR II drivers v2.10 from http://fr.software.canon-europe.com/
I converted the 64 bits rpm files using alien and I installed them :
    alien cndrvcups-common-2.10-1.x86_64.rpm
    alien cndrvcups-ufr2-uk-2.10-1.x86_64.rpm
    dpkg -i cndrvcups-common_2.10-2_amd64.deb
    dpkg -i cndrvcups-ufr2-uk_2.10-2_amd64.deb

Then I added the printer in the ubuntu printer manager. Everything went smoothly, but when I printed the test page (or anything else), I got only this on the paper :
    **** Unable to open the initial device, quitting.

It took me some time to understand that some part of the 64 bits driver are still 32 bits and depends on some other 32 bits libs, so I installed ia32-libs :
    apt-get install ia32-libs

And after this, the printer is working perfectly !