CUPS not starting at boot

Asked by lively on 2010-08-20

I noticed that my system tray HPLIP icon disappeared this week.
This appeared to coincide with an update.
Initially I thought it was an issue with the HPLIP but after reinstalling it, I found that I still had issues.
I dug around and discovered a partial answer to my problem. CUPS was not starting at boot.
I reinstalled CUPS and then I could start HPLIP but it still didn't start at boot.
I followed the advice on another site and added a script to force CUPS to start. All is now well with CUPS however, HPLIP must now be started manually, it doesn't start at login as it used to.

This is very frustrating since everything worked before the update.

Question information

English Edit question
Ubuntu cups Edit question
No assignee Edit question
Last query:
Last reply:

add the commands to start the relevant services in /etc/rc.local ABOVE the 'exit 0' line

This will run as root (no sudo needed) and should make things nice

lively (doratheexplorer) said : #2

Thank you,
Can I put the short command in here "hp-toolbox" or must I replicate the complete path?
I'm a bit of a novice...
Would this work to get mediatomb-daemon to start at boot too?


sebikul (sebikul) said : #3

there is an easy way to do that, go to System->Preferences_>Startup Programs and add an entry with the following details:

Command: "hp-systray"
Name: *you can choose

you can do the same with the "mediatomb-daemon" daemon, just change the command as shown above

lively (doratheexplorer) said : #4

Hp-systray is already in the startup programs but is not starting up
I have tried adding the media daemon to the start up programs in this way also and it does not work.
I have even tried adding the command to run in terminal - still no go.
Both products start just fine when started manually.
Thanks - still trying everything I can think of!

Please tell your Ubuntu release...
and please be sure it is fully updated and upgraded i had same issue on a Ubuntu 10.04 but was dressed...

lively (doratheexplorer) said : #6

I have 10.04
I update every time there is a new update.
I have tried using the options tab in Startup Applications to remember current running applications.
That doesn't work either.

lively (doratheexplorer) said : #7

As a last resort I marked Gnome Session Manager for re-installation in Synaptic Package Manager.
Re-installed it and shut down.
When I rebooted, the HP print manager started as it should.
Mediatomb is still stubbornly refusing to start when my session starts though.
I put the command mediatomb -d in the startup applications manager. This command starts the mediatomb daemon from either terminal or alt F2/ run application but not apparently from startup apps.
Any ideas?

Can you help with this problem?

Provide an answer of your own, or ask lively for more information if necessary.

To post a message you must log in.