Cups not starting on boot

Asked by Filippo Garavaglia on 2010-05-04

Ubuntu 10.04
To let the system recognize (and install) a printer (Hp Officejet 5610 and Deskjet 3820) I always have to (re)start the cups via terminal
sudo /etc/init.d/cups restart
(even start works)
Tried putting it into startup applications, no results.
I have all the permissions and my /etc/network/interfaces contains the values
auto lo
iface lo inet loopback

as suggested in
http://ubuntuforums.org/showthread.php?t=1416651

Still no results.
What happened? There wasn't this issue on 9.10.

Note that it's a similar bug to https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/500520 but I don't have issues with bluetooth or anything else, just with cups.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups Edit question
Assignee:
No assignee Edit question
Solved by:
Filippo Garavaglia
Solved:
2010-05-04
Last query:
2010-05-04
Last reply:
2010-05-04
Michael DePaulo (mikedep333) said : #1

Try using the program "rcconf" (that's its name in the repos.) I used that recently to adjust startup services.

Nope, problem not solved, rcconf says all the services are on at startup, tried to turning off and then on again, nothing changes, I still need to start cups manually.

Reinstalled again (3rd time) the whole cups package kinda hopelessly, it solved the problem (?????).