cups-pdf backend failure in 9.04

Asked by kiriath-arba on 2009-12-02

When I go to the cups browser interface, the following appears next to the PDF printer name: "/usr/lib/cups/backend/cups-pdf failed"

I have tried reinstalling cups-pdf 2.5.0-1ubuntu1 and the ~/PDF folder certainly existed beforehand.

Never had any trouble with cups-pdf in 8.04 on same machine (2 different releases of ubuntu reside on 2 different partitions, with /home folder also on separate partition, correctly set-up in fstab file). Output always sent to ~/PDF successfully in 8.04. Nothing being output to ~/PDF now nor in /var/spool/cups-pdf/ANONYMOUS or /var/spool/cups-pdf/SPOOL but I imagine if the backend is failing the printing process wouldn't even reach this stage in any case (?)

Seems to be similar to bug listed here https://lists.ubuntu.com/archives/universe-bugs/2009-March/060066.html Have tried suggested fixes 1 and 2 without success.

May have overlooked something, thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cups-pdf Edit question
Assignee:
No assignee Edit question
Solved by:
kiriath-arba
Solved:
2009-12-03
Last query:
2009-12-03
Last reply:

solved with:

sudo aa-complain cupsd