Manual upgrade to a higher version of cryptsetup

Asked by Jabb on 2019-09-24

By default, Mint 19.2 and Ubuntu 18.04 have cryptsetup version 2.0.2
Because of this error, I need version 2.2.0
https://gitlab.com/cryptsetup/cryptsetup/issues/484
Can anyone answer if I can manually install? https://packages.ubuntu.com/eoan/cryptsetup
Can any problems occur? I will not break the system?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu cryptsetup Edit question
Assignee:
No assignee Edit question
Solved by:
Jabb
Solved:
2019-09-24
Last query:
2019-09-24
Last reply:
2019-09-24

Mixing between releases will work but you will get a big mess of dependencies and will put you in an unsupportable situation.

If you log a bug and state the issues and they are significant then the package will be updated sooner rather than later.

Jabb (jabbo68) said : #2

Thank you very much.
I have sent a bug report.