sound not thruogh creox

Asked by electrahogg42

sound comes through my speakers can even use recorder to record but creox just sits there how do i get the effects to work

Question information

English Edit question
Ubuntu creox Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
JimTonti (jtonti1) said :

The creox advertising blurb (as is seen in Ubuntu and other sites on the web) states "[creox] can be connected to the JACK sound server (, and the output sound can be routed to the other JACK-aware applications." A careful read of the creox website at says, in subtly different language, "As Creox is a JACK application, the output sound can be routed to the other JACK-aware applications, and the audio input can be taken as the output from the other JACK client." Neither of these appear to have been written by a native speakder of English, and hence may be somewhat confusing. What these *should* also include is
"creox is a JACK application and requires JACK to run." (Running creox without JACK installed and running may result in a null error message dialog appearing, with no further guidance.)

Before you may successfully run creox, you must install the JACK daemon 'jackd'. (Search for it using the Synaptic Package Manager or your favorite install tool.)

I am currently running Ubuntu Dapper Drake 6.06LTS. To get creox to run, I had to run both jackd and then creox as superuser using 'sudo' from the command line using the Terminal application. (Terminal is found under the Ubuntu menu 'Applications' 'Accessories'):

>sudo jackd -d alsa& {This runs the JACK daemon in the background (don't forget the '&'),
                                              and 'hooks' it to the ALSA sound device}
>sudo creox& {Runs the creox application}

Then click the 'gear' icon (or hit the 'space' bar on the keyboard) to enable creox. If you get an error dialog box at this point, you may not have jackd running properly. You can see if jackd is running by typing 'ps -e | grep jackd' on the command line. If it shows up with a process ID, it's running.

Note that there were *lots* of error messages and warnings after each of the above commands (jackd and creox), but both seemed to work OK in spite of this on my Dell C610 laptop. Note that sudo will prompt you for your password at least once before running jackd.

Also, you may be unable to run any 'non-JACK' applications (e.g. gtkguitune, a nifty graphical guitar/instrument tuner application)
after the JACK daemon is started.

Good luck!


Revision history for this message
zyzstar (zyzstar) said :

Hi. I'm author of creox (but not the creox package maintainer). Thanks for this info.
Note that there is a "JACK sound server" in the list of requirements on the creox website.
I admit that documentation is terrible and next to none.
The null error message is the problem; it used to work with a proper error message explanation but they must have changed something in a jack library. I haven't touched creox sources for few years.

Revision history for this message
portamenteff (john-shakingthetree) said :

Script that works for me in Intrepid Ibex, AMD64 system.
The jack server output needs to be piped into the Creox. got it? :)
I'm playing guitar with effects right now.

 sudo jackd -d alsa | sudo creox

I tried many other syntaxes to get this thing working. Then I said "no this can't be that simple."

Revision history for this message
Everthon Valadão (valadao) said :

hey guys, there's no need for sudo! I just ran the following command

(xterm -e "jackd -d alsa" &) && creox

and everything worked like a charm :)

P.S.: there is any default presets?

Revision history for this message
Nick Morse (nickgeetar87) said :

You guys shouldn't have to even run it in terminal. Have you guys added yourself to the Audio file.Try this command to become part of the audio group.

*Sudo adduser yourusername audio

Once you do that you should now be a part of the Audio Group. You shuouldn't have to even go into terminal for booting up jack or creox. I know this is kind of a duh question but you guys have the rt-kernel installed also right?

Can you help with this problem?

Provide an answer of your own, or ask electrahogg42 for more information if necessary.

To post a message you must log in.