Any chance of perl 5.26 ubuntus getting cpanminus 1.7043, or one with a backported PERL_USE_UNSAFE_INC change to it?

Asked by andremar on 2018-01-12

I am quite new to launchpad, so this might not be the right place to ask this

Perl 5.26 remove `.` from @INC by default, and as a result, installers (like cpanminus et al) would add `PERL_USE_UNSAFE_INC` to add `.` to @INC again during configure, build, test and install steps so that old packages that use `Module::Install` for instance (or other packages in `.` would still be installable, but runtime being at least somewhat more secure).

In debian there is perl 5.24 and cpanm 1.7042, which work fine, but in ubuntu 17.10 there is perl5.26 and cpanm 1.7042, which don't work for installing all modules

Any chance of upgrading or patching cpanminus in ubuntu 17.10?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu cpanminus Edit question
Assignee:
No assignee Edit question
Last query:
2018-01-12
Last reply:
andremar (omega-palle) said : #1

I tested 1.7043 from 18.04, and that seems to work for me, so not an urgent issue

Can you help with this problem?

Provide an answer of your own, or ask andremar for more information if necessary.

To post a message you must log in.