10.10: Chmod

Asked by peter on 2011-01-24

In a terminal I entered chmod u+x /opt/lampp/htdocs/testdb

ls -la /opt/lampp/htdocs/testdb:
drwxr-xr-x 15 root root 4096 2011-01-19 14:29 .
drwxr-xr-x 5 nobody root 4096 2011-01-19 13:52 ..
drwxr-xr-x 10 root root 4096 2011-01-11 04:58 administrator
drwxr-xr-x 2 root root 4096 2011-01-11 04:58 cache
drwxr-xr-x 12 root root 4096 2011-01-11 04:58 components
-rw-r--r-- 1 root root 1700 2011-01-19 14:28 configuration.php
-rw-r--r-- 1 root root 2425 2011-01-09 03:40 htaccess.txt
drwxr-xr-x 4 root root 4096 2011-01-11 04:58 images
drwxr-xr-x 2 root root 4096 2011-01-11 04:58 includes
-rw-r--r-- 1 root root 1394 2011-01-09 03:40 index.php
-rw-r--r-- 1 root root 1273 2011-01-11 04:58 joomla.xml
drwxr-xr-x 4 root root 4096 2011-01-11 04:58 language
drwxr-xr-x 6 root root 4096 2011-01-11 04:58 libraries
-rw-r--r-- 1 root root 17816 2009-12-12 16:44 LICENSE.txt
drwxr-xr-x 2 root root 4096 2011-01-11 04:58 logs
drwxr-xr-x 8 root root 4096 2011-01-11 04:58 media
drwxr-xr-x 25 root root 4096 2011-01-11 04:58 modules
drwxr-xr-x 10 root root 4096 2011-01-11 04:58 plugins
-rw-r--r-- 1 root root 4493 2011-01-09 03:40 README.txt
-rw-r--r-- 1 root root 301 2009-08-12 19:12 robots.txt
drwxr-xr-x 6 root root 4096 2011-01-11 04:58 templates
drwxr-xr-x 2 root root 4096 2011-01-11 04:58 tmp

How can I make all ot them for the root executable? Thanks in advance.
Peter

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu coreutils Edit question
Assignee:
No assignee Edit question
Solved by:
peter
Solved:
2011-01-27
Last query:
2011-01-27
Last reply:
2011-01-27

This question was reopened

Here some doc http://en.wikipedia.org/wiki/Chmod but why you are doing this...?
Are you installing htdig ?

peter (peter-neuweiler) said : #2

No, I have problems with the Joomla installation. I miss permissions.
Peter

Please read https://help.ubuntu.com/community/Joomla i don't think you must made the files executable for the root user...

peter (peter-neuweiler) said : #4

solved

peter (peter-neuweiler) said : #5

Thanks. But nothing helps. I have always the same problems. And I guess, I can't help my self.
Peter

Manfred Hampl (m-hampl) said : #6

What is the exact problem?

Up to now you described your attempts to solve a problem with Joomla, but you did not give any information what the problem is, and why you think setting execute permissions on text files should help.

Maybe we can help better if you start from the beginning and show what the error messages (or problems or whatever) in joomla are!

peter (peter-neuweiler) said : #7

Ok.

If I will upload in Joomla a picture in a new article, I get the error message Warning: Failed to move file! Unable to upload file.

If I will update a CSS file, I will get the error message: Could not save data. Error: An error occurred. The file css/black.css could not be saved.

These are the problems. Can you help? Thanks a lot.
Peter

Manfred Hampl (m-hampl) said : #8

Have you follwed the instructions to set the access rights in https://help.ubuntu.com/community/Joomla#Configure%20Access%20Rights

As far as I can see you are using a different directory tree, so you have to adapt the script

Must most probably read something like the following:
# Allow writting only in places Joomla! needs to write to (more secure)
sudo chown -R root:root /opt/lampp/htdocs/testdb # instead of /var/www/joomla
cd /opt/lampp/htdocs/testdb # instead of /var/www/joomla
PLACES='
administrator/backups
administrator/components
administrator/modules
administrator/templates
cache
components
images
images/banners
images/stories
language
mambots
mambots/content
mambots/editors
mambots/editors-xtd
mambots/search
media
modules
templates
'
for i in $PLACES; do
    sudo chown -R www-data:www-data $i
done

cd /opt/lampp/htdocs/testdb # instead of /var/www/joomla
sudo find . -type f -exec chmod 644 {} \;
sudo find . -type d -exec chmod 755 {} \;

(P.S.: use with caution, check if it is in line with your settings, no guarantee given)

peter, please close this question and open a question on Joomla. This question is on the chmod(1) command from the coreutils package and as such the people getting emailed every development of it are coreutils people, not Joomla people. I expect Joomla people could help a lot more with this particular problem, which seems very Joomla specific, and they will know how to do the odd bit of chmod too.

peter (peter-neuweiler) said : #10

No Joomla people can't help.
Peter