How to prevent conky from populating ~/.xsession-errors

Asked by Vish on 2009-08-14

I use several if_mounted , and if_* variables in my conky , these keep populating the ~/.xsession-errors file when the drives are not mounted, while these errors are not major. the other xsession-errors get overwritten , since he conky output is for every minute.

Is there a way to prevent such errors/output from being written in the ~/.xsession-errors.

Also , why is this being done? IMO , it seems like an overkill.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu conky Edit question
Assignee:
No assignee Edit question
Solved by:
Cesare Tirabassi
Solved:
2009-08-19
Last query:
2009-08-19
Last reply:
2009-08-19
Cesare Tirabassi (norsetto) said : #1

As mentioned in bug 405188, a simple workaround is to redirect stderr to /dev/null or a log file.
The way conky is designed now, file system stats are collected regularly even for partitions that are iffed. The only advise I can give you is to report this upstream (a fix for bug 405188 will not necessarily address this aspect).

Best Cesare Tirabassi (norsetto) said : #2

It should also be mentioned that conky can be run with the -q, --quiet option if one doesn't want *any* output.

Vish (vish) said : #3

Wow thanx , that really solved the problem.

Vish (vish) said : #4

Thanks Cesare Tirabassi, that solved my question.