Computer-janitor not working

Asked by MadhuSoodanan on 2011-11-22

I am using Ubuntu 11.10. When installed, there was no "Computer-Janitor". So I installed a Canonical item--Version:
computer-janitor 2.1.0-0ubuntu6. Its name given in 'Ubuntu software center' in bold letters is - " Clean up a system.........a freshly installed one" and the command given in 'Ubuntu software center' is--
computer-janitor

Output:
-------------------------------
                             -desktop:~$ computer-janitor
usage: computer-janitor [-h] [--version] {find,ignore,unignore,clean} ...
computer-janitor: error: too few arguments
                             -desktop:~$
------------------------------
How can I remove unwanted items?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu computer-janitor Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-11-24
Last query:
2011-11-24
Last reply:
2011-11-23

go to filesystem then /usr/share/computerjanitor and look for a file named computer-jantor-gtk. run it and you will get a GUI to clean the system.

MadhuSoodanan (mt-madhu) said : #2

In share, I have 'computerjanitor' (not computer-jantor-gtk) and in it there are 6 files ( ~egg-info, ~app, ~ord, plugins, computer-janitor, janitord ). Which one should I open?

I suggest you install bleachbit, I find it does a better job but watch the settings you use or it can remove settings you want and avoid options which say they will take a long time

Run the app as root and your user and have as many apps CLOSED as you can.

MadhuSoodanan (mt-madhu) said : #5

Installed BleachBit. A good one indeed. But APT/autoclean & autoremove couldn't clean completely. BleachBit's Output is:

E: Could not open lock file /var/cache/apt/archives/lock - open (13: Permission denied)
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
----------------------------------------------------------------------------------------------------------
>Run the app as root and your user and have as many apps CLOSED as you can.

   Would you please make it clear?

the bleach bit requires to be run as root to work efficiently.
 you can find 2 options in installed programs for bleach bit. 1. bleach bit
and 2. as root(bleach bit).
run it as root and see the magic.

alternatively launch bleachbit from terminal a

sudo bleachbit

and enter the admin password.

Also make sure you don't have software centre open and that no updates are running

MadhuSoodanan (mt-madhu) said : #8

Thanks actionparsnip, that solved my question.

MadhuSoodanan (mt-madhu) said : #9

Thanks Actionparsnip. Your suggestion solved the problem. I saw BleachBit(as root) just after I sent my last message.
Murali Krishna, you are right. BleachBit is a good one indeed. Thanks.