Compiz config settings manager unity restore

Asked by Henry Folorunsho on 2012-02-22

Hi Guys

i manage to restore my computer back. then i went to compizconfig setting manager, to enable rotate cube. it now ask me to disable desktop wall and ubuntu plugins, i now restart the system, lost all icons on the desktop cant see anything apart from my background picture, am using the guest account to send this mail,

i just want to be creative and understand ubuntu very well, that is why am faced with different kinds of problem every day,

i have tried this output on my guest account

cd ~/Downloads
sudo apt-get install compiz-fusion-bcop compiz-dev \build-essential libtool \libglu1-mesa-dev libxss-dev \libcairo2-dev git-core
git clone git://anongit.compiz.org/users/soreau/scripts
cd scripts
./compiz-addons install all
nohup compiz --replace &

but i did not give guest account any previlage to install software's

please help me

Henry

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compizconfig-settings-manager Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-02-22
Last query:
2012-02-22
Last reply:
2012-02-22
Sam_ (and-sam) said : #2

When assigning the right package then a click on 'Answers' on top of this page is helpful.
It will display lots of solved questions regarding the subject.
https://answers.launchpad.net/ubuntu/+source/compizconfig-settings-manager

Henry Folorunsho (henryxav) said : #3

thanks

i tried this option.

Try to do this:
1. Login and open a terminal by hitting CTRL + ALT + T (if not work login with Unity 2D)
2. Insert and run this command:
sudo apt-get install compizconfig-settings-manager

3. Now in the terminal run:
ccsm

4. In the new window enable the plugin called "Ubuntu Unity Plugin"
5. Restart. (If you have selected Unity 2D at the 1 step, come back to Unity 3D)

nothing seem to work.

henry

at the login screen press CTRL+ALT+F1 and log in
Then run:

compiz --reset

If it moans then try logging in as your user in the graphical way and press CTRL+ALT+T then run the same command.

Henry Folorunsho (henryxav) said : #5

thanks

i tried logging in with CTRL+ALT+F1 and ran the output and logged in. it has 3 updates. the i ran that output it said fatal error

do i need to put sudo.

the CTRL+ALT+T nothing happens

henry

Henry Folorunsho (henryxav) said : #6

Thanks

i manage to reset with unity --reset,

when i login i used the safe mode and type the output. but i had the old launcher and menu toolbar, so i right click at the end of the panel to delete,

i hope i have done the right thing. i have not restart the yet

Sam_ (and-sam) said : #7

In comment #3 you've installed ccsm although it was already installed according to your entry post.
< ... then i went to compizconfig setting manager, to enable rotate cube >

Please leave compizconfig-settings-manager assigned since playing with it introduced the issue and not unity.

In future release there will be a clear warning to users on initial opening of ccsm about it's usage risk and in addition the unity-plugin can't be disabled.