Problem with video card

Asked by frankpr on 2007-05-19

I, thinking I was solving a graphics effects problem with ubuntu 8.04, somehow managed to mess up my ability to change my screen resoultion and etc. The message that I get when I try is this:

The X Server does not support the XRandR extension. Runtime resolution changes to the display size are not available.

I am running on a Dell, nvidia is my graphics card. Can someone help me get things back to the way they were? Obviously, I am computer retarded, so you might want to keep any help in layman's terms. THanks for any and all help!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Solved by:
frankpr
Solved:
2007-05-20
Last query:
2007-05-20
Last reply:
2007-05-20
Cesare Tirabassi (norsetto) said : #1

gtk-window-decorator is part of the Compiz package. It is possible that installing and trying to configure Beryl has corrupted the Compiz installation.
Try to reinstall Compiz:

sudo apt-get install --reinstall compiz

Note that compiz is just a metapackage, the real packages are its dependancies which should be installed automatically by apt-get.

frankpr (acefrankpr) said : #2

I tried that command but it didn't worked. Thank you anyway!

Cesare Tirabassi (norsetto) said : #3

Would you mind telling us the error message?

Best frankpr (acefrankpr) said : #4

Error: Failed to execute child process "gtk-window-decorator" (No such file or directory).

Thank you to everyone for helping. I could not wait so what I did to solve the problem is installing Ubuntu again. If somebody knows about this problem, and have a better solution, please share it with us. Take care!

NT (biggy-bang99) said : #5

What kind of videocard do you have?

frankpr (acefrankpr) said : #6

Intel Corporation
82852/855GM Integrated Graphics

I have the same problem, here is the error message from apt-get:

michel@cletus:~$ sudo apt-get install --reinstall compiz
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  compiz: Depends: compiz-fusion-plugins-main (>= 1:0.0.0+git20070711) but it is not going to be installed
          Depends: compiz-fusion-plugins-extra (>= 1:0.0.0+git20070711) but it is not going to be installed
E: Broken packages
michel@cletus:~$

Kazade (kazade) said : #8

sudo apt-get install compiz-gnome should fix it. I had the same problem just now :)