Google Earth flashes and I cannot see clearly

Asked by Mohammad Alhobayyeb on 2009-02-02

I have installed google earth from medibuntu but I found that it is flashes.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-07
Last reply:
2009-09-18

If you have Visual Effects enabled...

Please try to disable compiz from menu System → Preferences → Appearance
[ Visual effects ] Tab set them to "None" and retry run Google Earth

Hope this helps

Mohammad Alhobayyeb (mih1406) said : #2

But this will erase all my compiz configurations :(

Can I save the configurations of compiz first??

I never save the compiz configuration when i disable it but if you want, you can make a copy of compiz hidden directories under your home directory:

.compiz and .compizconfig

Open a Terminal from the menu Applications → Accessories → Terminal and type:

cp -r .compiz .compiz_saved
cp -r .compizconfig .compizconfig_saved

Then disable compiz

Hope this helps

Mohammad Alhobayyeb (mih1406) said : #4

None!!

I think this is not a soluation
Is their and thing to do for google earth to work with compiz

Tom (tom6) said : #5

Hi :)

Have you got an ati graphics card?

Tom (tom6) said : #6

If you have an ati card then there may be a work-around. Not sure if this works with other cards but you can always change it back easily enough if it doesn't work. Open a terminal console by going up to the to taskbar and click on

Applications - Accessories - Terminal is near the end of the sub-menu

into the terminal/command window/console type

gstreamer-properties

note that as you type if you press the tab key it tries to autocomplete in a predictive text way - if it hesitates then tapping it twice shows the list of different possible commands you could be typing. Anyway a gui should have appeared. Click on the Video tab and change the top option "Output" from "Automatic" to "...(no Xv)". That should hopefully fix the problem.

Good luck and regards from
Tom

Mohammad Alhobayyeb (mih1406) said : #7

Yes, I have.

Is not there any way to configure Google Earth to (no Xv)
Because gstreamer-properties already (no Xv)

Tom (tom6) said : #8

Dohhh, sorry i don't know - i though that was a 'global' setting. try preferences at the bottom of the Edit or Tools menu - i don't know Google Earth but that's usually where to look in packages.

Ok, next suggestion is to try switching the ati drivers on, if its already active then disable it and see if that makes a difference. This will probably require you to reboot the machine - i don't think just logging off and on again is enough, i'm not sure. If there's no effect than switch it back afterwards, if you prefer. Ok, go up to the top taskbar and click on

System - Administration - Hardware Drivers

It would be great to hear that something here has solved this but it's very probable that Marcobra was right.

Even if you can't save the settings you can take screenshots of how they are set up. Also i've always found it a lot easier and faster to do something a second time than it took first time. Hours of hunting around and testing things out are just done quickly in a few mouse clicks.

Ubuntu is written to be able to make maximum advantage of any system it's on and is geared towards top-end machines. Some of the effects make well work on machines that aren't the ultra latest massively expensive and unnecessarily high-performance machine but not necessarily all on at the same time. Ubuntu always compares favourably to any other OS on that same machine

I tend to find all the fancy desktop effects just distract me from getting on with work anyway. One other thing that Ubuntu is fast with is file-transfers from or too multiple sources, together with greater stability and far less security risks it would seem the obvious choice in many places where Windows is still thought of as best - mostly because people haven't tried the alternatives. Personnally i would always recommend a dual-boot system because some games and things work better in Windows
https://help.ubuntu.com/community/WindowsDualBoot

Sorry if we haven't been able to help. I hope you have some luck in sorting this out
Regards from
Tom

PS Apparently there has been a new ati driver just recently released but it might be just a rumour and i haven't been able to find it yet. Perhaps it would help though.

PPS The hardware manufacturers seldom invest anything in developing decent OpenSource drivers and don't seem to realise that making one driver OpenSource would mean that OpenSource Developers would quickly make it available on the handful of different main Linux's and on Macs too. Instead they would rather cling to their secrets and complain that there's too much variety in the world!

Mohammad Alhobayyeb (mih1406) said : #9

That is tom I tried first in the google earth tools or preferences but I could not found any thin about what is the video output it uses Xv or No Xv.

And my question here how can I chagnge this for google earth is there any way I do not want to disable the ATI I knew that this solve the issue but I am thinking if there is a way to let google earth uses Xv or No Xv

Thanks Tom
Mohammad

Tom (tom6) said : #10

Oh i just meant turn the ati proprietary driver off temporarily. If that does fix the problem then it would help us pin the problem down and try to find some work-around for when you've got google-earth running.

I'm not saying to turn it off permanently, just for a little while to see what happens.

Good luck and regards from
Tom :)

Mohammad Alhobayyeb (mih1406) said : #11

I have done that and google earth works fine and also it works if the 'Right Click - Change Desktop Background - Visual Effects' is None

Tom (tom6) said : #12

So you now have 2 ways of running Google Earth without any flashing? either turning off the ati driver or turning off the desktop effects works?

Sorry i have been so long getting back to you but i have at last found a little something that may help. About halfway down the page is a section called "Known Issues"
https://help.ubuntu.com/community/CompositeManager
if you can use their command to get google earth working then you'll just have to find someway of scripting it so that it runs each time you click on google earth. It temporarily disables the ati driver but i am not sure whether it does that for the whole desktop or just for the application.

Good luck resolving this.
Regards from
To :)

Tom (tom6) said : #13

If you are still having trouble with this then please post it as a new question. Only the most recent questions tend to get looked at so posting/reposting a question just before america arrives online gives the best chance of getting a good few answers.

If the problem has been resolved then please follow the link to the forum thread and mark it as Solved.

Good luck and many regards from
Tom :)

Mohammad Alhobayyeb (mih1406) said : #14

I cannot do anything these days, I have final examinations.

Tom (tom6) said : #15

Aww, hey good luck with those :)
Regards from
Tom

Daniel Castro (castromd) said : #16

Any solutions for this?

Tom (tom6) said : #17

Please post this as a new question now. there are some new people at the front desk and one of them may well be able to help much better than i can.
https://answers.launchpad.net/ubuntu/+source/compiz/+addquestion

However, about halfway down this next link is a section called "Known Issues"
https://help.ubuntu.com/community/CompositeManager
if you can use their command to get google earth working then you'll just have to find someway of scripting it so that it runs each time you click on google earth. It temporarily disables the ati driver but i am not sure whether it does that for the whole desktop or just for the application.

Good luck resolving this.
Regards from
Tom :)

PS Glad exams are over, i've got fingers crossed for a good result there

vijay.sengar (vijay-sengar) said : #18

i tried to disable compiz from menu System → Preferences → Appearance
[ Visual effects ] Tab set them to "None"

this works

thanks---marcobra (Marco Braida)

Can you help with this problem?

Provide an answer of your own, or ask Mohammad Alhobayyeb for more information if necessary.

To post a message you must log in.