Cannot get ALT+SYSRQ+? to work via manual key press in Ubuntu 8.10

Asked by Aiden83 on 2009-01-08

My system hangs often due to Compiz bug. I have discovered that I can CTRL+ALT+backspace to restart X and the system returns to normal. However I also discovered that I cannot ALT+SYSRQ+1 or ALT+SYSRQ+t or ALT+SYSRQ+b. I was trying to gather information dump to report the bug. How can I get this to work? I have enable it by saving 1 to /proc/sys/kernel/sysrq. I can also CTRL+ALT+F1 and then from tty1 successfully run "echo r | sudo tee /proc/sysrq-trigger" . But from X-session I cannot manually press ALT+SYSRQ+r etc.

This brings me to my second question - I have lodged a bug report for this problem already after Apport detected it. Why doesn't Apport detect this problem anymore? Is it that it has detected it in the background?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Solved by:
Matt Arnold
Solved:
2009-01-09
Last query:
2009-01-09
Last reply:
2009-01-08
Best Matt Arnold (mattarnold5) said : #1

In answer to you first question, the Ubuntu kernel is not compiled with magic_sysrq set. To get it to work you need to compile a custom kernel. There are several dozen howtos on the web but the safest way to go is the official Ubuntu instructions, you can find these at https://help.ubuntu.com/community/Kernel/Compile.

Aiden83 (aidendeem) said : #2

Thanks Matt Arnold, that solved my question.

Robert (robbies-) said : #3

Matt, You say sysrq is not compiled into the kernel but why can I get it to work when I press alt ctrl f1? Why doesn't it work under X? (on an IBM t40 and hp nx7400

Aiden83 (aidendeem) said : #4

Robert, I also can use CTRL+ALT+SysRq from tty, but not from X. Interesting to know if this is enabled in the kernel separately for tty session as than for X session.

Robert (robbies-) said : #5

I have never heard that it could have been enabled for console and not for x. I believe it has to with x's keyboard settings (on my notebook the alt sysrq combination would take screenshots - that I have currently disabled but still alt sysrq won't work. I also thought it had to do with compiz but with compiz disabled I can't get alt sysrq to work either. Gents, can anyone help?

ChrisLees (christopher-lees) said : #6

This must be why there is no meaningful information from gnome-system-log after a crash. When my system is on the verge of crashing, I press Alt-SysRq-S to sync everything to disk including kernel logs, but there's rarely any information in the logs afterward about the crash.

Compiling a new kernel with SysRq is not an option for me - the machine goes down before the compile finishes. It should be there by default like it was in earlier versions!