Compiz hangs at first click on logged in desktop after upgrade to 12.10 - can work around by deleting .compiz/session/* first.

Asked by phxphun1 on 2012-10-20

After upgrading from 12.4 to 12.10, I found that once logged in, I can move the mouse around and items highlight as I mouseover them, as well as the launcher seeming to respond appropriately too. Upon first click, however (whether it be on the launcher, taskbar, or even a right-click on the desktop) compiz or unity (inextricably linked now?) hangs. The mouse pointer can be moved about freely, but otherwise no further action is possible.

The rest of the system still runs (I once tried to open email, and despite the screen being frozen and email not appearing, it apparently was able to fetch mail and I heard it play the new-mail-sound). I can even ctrl/alt/f2 and log in to a full-screen terminal session.

At first I suspected video driver issues, as I've had them before. This is on an ASUS X83V laptop with Nvidia GeForce 9300M. I tried removing and reinstalling unity as well as trying Nouveau and the three variations of the proprietary Nvidia driver.

Then it occured to me that perhaps the issue was related to some sort of configuration issue - maybe leftover bits from 12.4 confusing 12.10. I tried the guest login, and everything worked flawlessly, possibly confirming my suspicion.

My next step was to delete .compiz/session from my home directory. Upon reboot, everything worked fine again. Problem solved? Apparently not - upon next boot, it hangs again as before. I also found that .compiz/session had been re-created. Deleting it via a terminal session then allowed me to reboot to a working desktop, but only once, unless I first deleted the contents of .compiz/session

Workaround: As a workaround, I've added a line to /etc/rc.local to delete the contents of .compiz/session at boot time:
     rm /home/my_username/.compiz/session/*

That seems to be working ok for me, but it still makes me wonder: Is there a more proper fix to my problem? or have I found a bug? While it seems to be working OK for me with my workaround, but I wonder if deleting the .compiz contents might break something else and/or deprive me of some functionality or other?

Anyhow, all comments are appreciated. If nothing else perhaps my workaround might help someone else with a similar issue.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-21
Last reply:
2012-10-21

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Have you also tried installing xfce4 package then loggin in to the XFCE session?

phxphun1 (phxphun1) said : #2

mike@mike-asus-laptop:~$ sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia
[sudo] password for mike:
  *-display
       description: VGA compatible controller
       product: G98 [GeForce 9300M GS]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:16 memory:fb000000-fbffffff memory:d0000000-dfffffff memory:f8000000-f9ffffff ioport:cc00(size=128) memory:fa000000-fa01ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux mike-asus-laptop 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
rc nvidia-173 173.14.35-0ubuntu0.2 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-common 1:0.2.71 amd64 transitional package for ubuntu-drivers-common
rc nvidia-current 304.51.really.304.43-0ubuntu1 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library
rc nvidia-current-updates 304.51-0ubuntu1 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library
rc nvidia-experimental-304 304.48-0ubuntu1 amd64 Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library
rc nvidia-settings 304.51-0ubuntu2 amd64 Tool for configuring the NVIDIA graphics driver
rc nvidia-settings-updates 304.43-0ubuntu0.2 amd64 Tool of configuring the NVIDIA graphics driver
mike@mike-asus-laptop:~$

No, not tried XFE. If it's a valid troubleshooting step, I could try, but I've no interest in using it on this box.

ok lets clean up this mess:

sudo dpkg -P nvidia-current nvidia-current-updates nvidia-experimental-304
sudo dpkg -P nvidia-settings nvidia-settings-updates
sudo apt-get clean
sudo apt-get update
sudo apt-get install nvidia-current

Reboot to test

phxphun1 (phxphun1) said : #4

Sorry, no fix :(

 I'm pretty sure I'd already tried that, or it's equivalent, but I went ahead and followed your exact steps (cut-n-pasted) in order, and also remembered to remove my workaround, and rebooted. While I noticed that it's obviously now on the Nvidia driver (I'd been trying Nouveau most recently), the Unity/Compiz hang-on-first-click issue is still there--exact same behaviour. Reinstating my workaround (deleting /home/mike/.compiz/session/* via /etc/rc.local) "fixes" it.

FWIW, my computer seems totally usable with my workaround. What might I be missing out on by bypassing .compiz/session? Granted, I shouldn't have to use such a workaround, but ... if it's an issue peculiar to my hardware, I suppose it is what it is.

i suggest you report a bug

phxphun1 (phxphun1) said : #6

OK... sounds like a plan. Thanks for the try anyway. I'll leave this open for a bit in case someone else has any thoughts.

Bug reported:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1069265

Alf Sagen (alfsagen) said : #7

Hi there phxphun1,
I have the exact same problem as you report here! My laptop is a Lenovo Thinkpad T500, pretty "plain & common", I'd say, and Thinkpads also have great Linux support in general. I've got dual graphics consisting of a dedicated ATI Radeon card and an on-motherboard Intel chip. I've configured BIOS to use only the on-board Intel graphics, mainly because the laptop's using less than half the power (really: battery is lasting double the time!), and I don't use any proprietary driver. Still, I'm reproducing the exact problem you're reporting, and my resolution has also been the same :-)

Honestly, I don't think the problem is related to graphics & drivers, but I haven't had the time to do any further debugging. However, I confirm that deleting any directories and files under ~/.compiz*/* is also resolving the problem on my side.

Furthermore, I may add that I'm usually working 1-2 weeks without rebooting my laptop (just closing the lid, making the computer go sleep), and I very rarely have problems even though I every day plug/unplug external monitor at my workplace (no docking, just plain VGA cable plugged/unplugged), and also when I'm using projectors in meeting rooms etc. Even though I used to have more trouble (especially under Ubuntu 11.x series with Unity), 12.10 is rather stabile except for the boot-up problem.

If I'm able to type into a terminal window under Unity after boot, I'm usually able to fix the problem temporarily by performing
  $ compiz --replace &

However, it will crash again, until I first delete the file structure under ~/.compiz*/* and replace compiz again.

If I'm not able to type into a terminal window under Unity (the same tty, normally tty7), the same procedure does NOT work from e.g. tty1 (typically using CTRL+ALT+F1 to fix problem). In this case even the following doesn't help:
  $ killall -9 compiz
  $ DISPLAY=:0.0 compiz --replace &

In these cases, I have 2 options:
  1) sudo shutdown -r now
  2) sudo service lightdm restart

The problem for both alternatives is that any open application under the existing session will be killed as well. (This isn't a huge problem when the compiz/unity crashes just after reboot, but was really annoying when it used to crash in the middle of the day, giving me no alternative but to kill all running applications including a couple of virtual machines under VirtualBox.)

Also, I suspect that our problem is related to systems being upgraded from earlier Ubuntu distros (mine comes from 10.10, as far as I remember) and/or is related to use of ccsm (Compiz Config Settings Manager).

Sorry for the long texting, and I'm happy to provide logs etc. if anyone interested.
(I'm currently creating a full image backup and plan to reinstall a clean, plain 12.10 install to see if that makes any difference.)

Brgds
/alfs

Alf Sagen (alfsagen) said : #8

Hello again everyone,
from my point-of-view it seems that in Ubuntu 13.04, the compiz problems are resolved. At least I haven't experienced any problems since my upgrade (which was done approx. a week after 13.04 was released....don't remember the date).

/alfs

Can you help with this problem?

Provide an answer of your own, or ask phxphun1 for more information if necessary.

To post a message you must log in.