Compiz crashes in Ubuntu 12.04 after update

Asked by murali on 2012-04-27

On fresh install, Ubuntu 12.04 ran Compiz alright. I ran the Update Manager, rebooted and Compiz was good. After installing Additional Drivers, i.e. Nvidia, Compiz crashed and nothing but wallpaper appears. Right-click on screen works and I clicked on Change Desktop Background, then All Settings. I went to Additional Drivers and uninstalled Nvidia. Rebooted and all is well again. Seems like a bug.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu compiz Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-27
Last reply:
2012-04-29

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Mark Keith (werewolf6851) said : #2

I have the same issue

resultes of "sudo lshw -C display; lsb_release -a ; uname -a ; dpkg -l | grep nvidia
--------------------
  *-display
       description: VGA compatible controller
       product: C61 [GeForce 6150SE nForce 430]
       vendor: NVIDIA Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:22 memory:fb000000-fbffffff memory:e0000000-efffffff memory:fa000000-faffffff memory:febc0000-febdffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux Vixen 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers
rc nvidia-current 295.40-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
rc nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

sudo dpkg -P remove nvidia-current nvidia-settings
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Then reboot

Kedar (kedar54) said : #4

I have the same problem! Rebooting did not fix my problem though

Mark Keith (werewolf6851) said : #5

I tried the above, and noticed a few things.
First off I use encrypted partions
Without nvidia, boot screen ask for passwords in a 'box' and indicates * for each letter typed
the LG FLATRON ew224 is detected as a Goldstar Company Ltd 22" with 1920x1080 resolution
with nvidia installed
boot screen looks like it's too big for monitor
password as asked as text, first partion password is "*" out (the root partion)
password for the second partion shows as plain text 'not good' (the home partion)
Monitor is listed as 'laptop'
resolution only 800x600

tried editing the xorg.conf file add 1920x1080 mode, but it was a no go.

Bertalan Fodor (fodber) said : #6

Nvidia released its 295.49 driver, expected to solve this problem.

Albert Zeyer (albertzeyer) said : #7

This still seems to be a problem. I just stumbled upon this. The updates from ppa:ubuntu-x-swat/x-updates fixed it.

Can you help with this problem?

Provide an answer of your own, or ask murali for more information if necessary.

To post a message you must log in.